Chevy Trailblazer SS Forum banner

1 - 6 of 6 Posts

·
Registered
TrailblazerSS
Joined
·
658 Posts
Discussion Starter #1
I need a stock y-pipe setup to get it up and running. PO had an exhaust shop hack in a really ugly aftermarket garbage.

Anything that isn't hacked up or have bad cats will do...lower the miles, the better.
 

·
Premium Member
2008 TB SS AWD 3SS
Joined
·
3,288 Posts
Ive got one off my 08, shipping might be expensive from Seattle though...PM me if really interested.
 

·
Registered
TrailblazerSS
Joined
·
658 Posts
Discussion Starter #3
Ive got one off my 08, shipping might be expensive from Seattle though...PM me if really interested.
Thanks...i'll hold out for a couple weeks and see if anything closer pops up first. It doesn't run yet so I'm not in a hurry :boohoo:
 

·
Registered
TrailblazerSS
Joined
·
107 Posts
Thanks...i'll hold out for a couple weeks and see if anything closer pops up first. It doesn't run yet so I'm not in a hurry :boohoo:
I have one with one cut in it. It has 70K miles. I am by Philadelphia. All you have to do is weld it back together. The cats functioned intended. If you are interested LMK and I will get pics.
 

·
Registered
TrailblazerSS
Joined
·
658 Posts
Discussion Starter #5
I have one with one cut in it. It has 70K miles. I am by Philadelphia. All you have to do is weld it back together. The cats functioned intended. If you are interested LMK and I will get pics.
PM Sent
 

·
imperial blue
2008 TrailblazerSS
Joined
·
328 Posts
i have a gm brand new y pipe.never been mounted
 
1 - 6 of 6 Posts
Top