Chevy Trailblazer SS Forum banner
1 - 13 of 13 Posts

·
Premium Member
TrailblazerSS
Joined
·
1,043 Posts
Discussion Starter · #1 ·
so lately when driving my 07 awd ss there has been a weird noise coming from the front...its hard to explain what type of noise. It almost sounds like a slight rubbing...almost like a train on deceleraton (but not as loud)...but the noise gets loud when doing 40mph and coasting. It also gets more noticiable on gradual turns at speeds of 30-40mph. At times I can feel slight vibrations in the steering wheel and they go away just as fast as they appeared. I still have some waranty left on it. I just had the trans flushed and installed a brake duct trans cooler. All the fluids are at the correct level. Has anyone else experienced this or know where to start looking at?
 

·
Registered
TBSS Black 2006
Joined
·
532 Posts
They would need to be replaced. I believe this is covered under your warranty. Otherwise it's around 133-150$ for the good bearing or take your chances with the 50$ eBay hub/bearing assembles.
 

·
Premium Member
07 TBSS
Joined
·
1,148 Posts
If ur not sure if its noise is from the drivetrain or the wheel bearing, what I like to do is drive at the speed that's its making the noise and if u can with no cars around you put it in natural and shut it off... If the noise goes away u know its in the drivetrain, if it stays then u know its in else where.. just my :2cents: BTW just make sure u don't lock the steering wheel lol u shouldn't be able to anyways..
 

·
Premium Member
TrailblazerSS
Joined
·
1,043 Posts
Discussion Starter · #7 ·
I'm in des plaines....I'll probably be making an appointment up by you soon Greg....tried what XMONTE suggested and the noise is still there when the car is off and in N.
 
1 - 13 of 13 Posts
Top