Chevy Trailblazer SS Forum banner

1 - 10 of 10 Posts

·
stupid white guy
TrailblazerSS
Joined
·
4,887 Posts
Discussion Starter · #1 ·
Whether you've seen my other thread or not, here's where I'm at. Started with crazy misfiring on cylinder #8 at about 5000 RPM. Switched plug wire with #1, and #8 still missed. Switched coil pack with #1, #8 still missed. Switched to a new plug in #8 and it still misses bad at high RPM.

How can I diagnose a weak valve spring?

Anyone ever heard of this with our engines?

Please help......
 

·
The Lurker
TrailblazerSS 06
Joined
·
13,844 Posts
Pull the valve cover and get a visual inspection first...A bent push rod will act like that too........
 

·
Premium Member
08 Trailblazer SS
Joined
·
1,044 Posts
I had the same thing and could never figure it out. The #8 exhaust spring snapped one night and ended up melting my intake manifold.
 

·
stupid white guy
TrailblazerSS
Joined
·
4,887 Posts
Discussion Starter · #4 ·
Was it covered under warranty? Did they replace top end or whole engine?
 

·
Premium Member
08 Trailblazer SS
Joined
·
1,044 Posts
Well since I have an e-fan and CAI the dealership was afraid to touch it. I ended up replacing it all myself. All I replaced was the broke spring and intake. I did a leak down test on #8 before pulling the head. The test was good so I just left the head on. It idles better and little to no misfires now.
 

·
TT AWD TBSS Jeep
TT AWD SS Pwrd Jeep
Joined
·
5,825 Posts
I would try swapping injectors too, you swapped everything but that. It might be going bad. You could try just testing ohm-age, but that wont tell the whole story. It wont take long to do, let us know how it works out!!
 

·
stupid white guy
TrailblazerSS
Joined
·
4,887 Posts
Discussion Starter · #7 ·
But is it possible for an injector to work perfectly under normal operating ranges, and then fall flat on it's face under heavy load?
 

·
Premium Member
2006 TBSS
Joined
·
1,712 Posts
Buddy, let me know if you want to try one of my stock injectors. I also have a spring compressor you can use if you want to swap a valve spring.
 

·
stupid white guy
TrailblazerSS
Joined
·
4,887 Posts
Discussion Starter · #9 ·
Thanks Neal. I've got all the stuff to do it, but just really don't want to you know? I just want to diagnose it accurately and know exactly what's going on. Pisses me off that I have always been able to figure this stuff out, and now I run into something that has me stumped.

And I am not the kind of guy to just start swapping parts.
 

·
TT AWD TBSS Jeep
TT AWD SS Pwrd Jeep
Joined
·
5,825 Posts
Yes, injectors under load can mess up at WOT. I had that same issue with my GN. The injector seemed fine at idle and part throttle, but couldnt handle the faster ramp up and down cycles at WOT. Think the coil was going that opened the solenoid. Made it a good time to upgrade injectors! :) You can start by ohming them. But that still wont tell if the coil inside the solenoid is going, as you can only ohm them outside of the circuit. You may also want to check the injector harnes for bad connections. Good luck!
 
1 - 10 of 10 Posts
Top