Chevy Trailblazer SS Forum banner
301 - 320 of 323 Posts

·
Registered
07 AWD 3SS
Joined
·
561 Posts
Discussion Starter · #302 ·
Im gonna change the oil then get it back together finally! Its mire quiet in terms of valvetrain/engine noise than the lq9 in the tahoe. Which is nice.
 

·
Super Moderator
TrailblazerSS
Joined
·
1,367 Posts
Man you guys got me wanting to buy internal parts.. take a broke aSS owner for boosted ride? Can't wait to see your results. Have you driven with the triple pod yet? Curious as to how much it increases the blind spot. Have a triple on my EG and it's barely noticeable vision wise.

Sent from my SM-G991U using Tapatalk
 

·
Registered
'07 3SS 2WD
Joined
·
444 Posts
"..sounds fuckin mean".

LOL. Wait until you stab the gas and it down shifts, blower whine until redline!
 

·
Registered
07 AWD 3SS
Joined
·
561 Posts
Discussion Starter · #310 ·
Ok, got the catch can in, looks like that will work. Gonna give it a little pssst pssst black rattle can. workin on gettin the bumper cover kit on, snazzy little piece, got this on the forum from i forgot who but i cant wait to fix that little area.! Small uppet radiator hose leak now that the t stat has opened a bit. Nbd par for the course
Tire Wheel Automotive tire Tread Vehicle

Hood Wood Automotive exterior Bumper Font
 

·
Registered
07 AWD 3SS
Joined
·
561 Posts
Discussion Starter · #312 ·
Well i havent got it into boost yet, but i am shocked at the difference in torque, even with then higher rpm range of the cam, the ls2 was never this torquey stock or with the 3k yank anything. Not bad, strokers eh
 

·
Registered
07 AWD 3SS
Joined
·
561 Posts
Discussion Starter · #313 ·
Definitely have a couple good heat cycles in, shes creakin and groanin. need the 160 stat. Experiment has concluded, 174 stat for the tahoe . Be changin that soon
 

·
Registered
07 AWD 3SS
Joined
·
561 Posts
Discussion Starter · #315 ·
Messin around with the aeroforce before ‘work’-
So ive always just used it for displaying 2 parameters, i was actually reading the manual (insert comment here) and it turns out this thing can do a lot more, which is cool. I think i can get it to display in ‘4 mode’ if I only have 4 params set in cyclic scan, i have eight right now. Some extra things in ‘controls’ like case relearn, trim reset, etc. cool. Nice little gauge. Gets a little small (the text) but cool.
Mobile phone Communication Device Automotive lighting Portable communications device Telephony

Font Gas Gadget Electric blue Darkness

Font Gas Electric blue Gadget Display device


Automotive lighting Gadget Gas Entertainment Technology
 

·
Registered
07 AWD 3SS
Joined
·
561 Posts
Discussion Starter · #316 · (Edited)
160 stat is a winner, of course; should have followed the threads to begin with lol.
A couple of tiny coolant leaks in my franken-hoses goin to the radiator, but nothin crazy. Lots of torque. Tryin out a green belt for shitzengigz. K081099HD.
Upper hose coupler is for the steam from the heads and the coupler on the lower is for the autocool’s water outlet temp. After zippin around the block, no higher than 186 and the fans bring it down to 179 in stop and go, 93 ambient with the autocool in the 8 o’clock position. Also made some camber/castor/toe adjustments so i dont chew up the meats before the alignment appt, nbd gents. Beer 30.
Next steps-
immediate- alignment, buy/install proper battery (using my bench battery)

1-dial tune in gradually, see how it runs in boost a little more
2-paint correction
3-clean up fan controller wiring/refine heat exchanger pump mounting (may get the brackets from zz performance)
4-see how the gauges work out, I may move some from here to there etc
5- change the fresh break-in oil out for Ams XL 10w40 after a few runs/hundred or so miles
6-install AC system with shortened hose (there's a thread in the how-to section), charge
7-send aeroforce to aeroforce for firmware update to get the quad numerical page vs bar graphs
8-work on snazzy hood vent clearance issues
9-work on hi amp alternator

Car Automotive parking light Land vehicle Tire Automotive side marker light
Automotive tire Hood Automotive lighting Yellow Automotive design
 

·
Registered
07 AWD 3SS
Joined
·
561 Posts
Discussion Starter · #317 · (Edited)
Working on tuning idle and sanity checking things...

Ok so right off the bat, narrowbands, as somewhat/partially expected are essentially worthless, targeting 14.9-15.1 in closed loop with only STFT on.
Sooo that means wideband and Open loop speed density, which is somewhat dangerous right off the bat, but I'm being very cautious on the pedal monitoring knock (haven't seen any yet and knock is definitely enabled in the tune) and obviously the wideband(s).

Just starting out with idle, which is a lot, right-
-Cold start behavior, does commanded AFR match actual, does rpm match what the computer is commanding for a given temp
-Hot start behavior, same as above
-light acceleration/watching for lean spikes (none, hitting 13.5 on mild tip-in out of boost), which is nice imo
-coast/coast down to stop, watching RPM etc

-Made some changes to Base running airflow, crank airflow, pulled some VE from the idle area.
-Also slashed the adaptive idle's over/under SA correction, even from stock GM its too much
-Ethanol monitor works fine, averaging 10.6%
-made some small changes to throttle following
-Hot Idling at 1.4-1.5 ms of pulsewidth at 52-54 kpa, 13.8-14.0 in park and neutral at the correct rpm, so that's decent and that's nice because I suspected the injectors might be a little too big but that doesn't seem to be the case (FIC 1000 at 3 bar). I'm trying never to be above 14.1 with E10.

All in all, the tune from PCM is pretty good on VE and SA, I'm glad I spent the money on that, as I kinda previously mentioned; I have no issue paying for a tune for a setup like this, kinda gives me an opportunity to compare, you know whole 'let's see what the pros do in a situation like this' and take some notes. I haven't really got into boost with any intention yet, I need to make sure the part throttle stuff is square before that happens... workin on it, tho. I suspect it will be fine, it looks good so far. besides whats the worst that can happen
 

·
Registered
07 AWD 3SS
Joined
·
561 Posts
Discussion Starter · #318 · (Edited)
Also running the RPM belt, seems to be fine for now (haven’t really tested it yet in boost, so jury’s out) with basically no stretch, tensioner is still at around 30-40%.

Aaand my HVAC mode actuator under driver side died whereas it was working fine two days ago, of course. CLICK CLICK CLICK CLICK AAAHHHH STFU

I did end up actually shimming the supercharger pulley out about 30 thou using some ‘custom’ small washers and longer pulley bolts, so thats good. Fixed the belt alignment issue, no more black shmegma rubber dust accumulating anywhere. we’ll see how that holds up

cooling situation seems fine, havent anything over 195 yet, and im doing alot of stop and go in the south bama sun, so thats nice. No oil in the coolant and vice versa, so thats good. Trans is also fine, but nothing has been really ‘put to the test yet’, like i was sayin. Nbd gents beer 30
 

·
Registered
07 AWD 3SS
Joined
·
561 Posts
Discussion Starter · #319 ·
This thing is an absolute animal. Eh its my first built and blown vehicle, so take that for what its worth, but wow. poor 4L70e, thats a lot, even for a built one. Oofda

need to get the break in oil out this weekend.

think I went a little overboard on this, but hey whatever
 
301 - 320 of 323 Posts
Top