Chevy Trailblazer SS Forum banner

41 - 43 of 43 Posts

·
"whitey"
2008
Joined
·
1,206 Posts
I had the same no start just click

Found that the positive side post battery terminal had corroded between the "raised tabs" on the inside of the cable (I was getting less than have of the connection). I took a wire wheel attached to a drill and polished the whole terminal to a "copper finish" and used some dielectric grease and worked flawless for a couple of months, then it started acting up again, but this time if you held the key in the start position it would finally turn over after a couple of seconds. So then replace the ignition switch
 

·
Registered
TrailblazerSS
Joined
·
67 Posts
Bringing up an old post mine will randomly just click from the starter like the batts dead. Checked battery its almost fully charged. Left charger on it for a couple hours and it started. Iv had it do same a few times before when it sits for 6 weeks i know the batts dead. Sometime if trying to boost it it will click click click then i f i try it again a minute later its stone dead nothing. My mom wants to buy it but these little issues are turning her off of it. HAHA 72 year old lady driving an SS love it.
 

·
Registered
Joined
·
1 Posts
Unless the cables are broken, missing insulation, shorting out or corroded then they will be fine.

It still sounds like a starter to me.
My husband said ours was the starter turned the key on at it clicked once. Means the starter is getting power so starter is bad Our mechanic is putting a new starter on it said same thing starter
 
41 - 43 of 43 Posts
Top