Chevy Trailblazer SS Forum banner

1 - 8 of 8 Posts

·
Registered
2006 TrailblazerSS
Joined
·
122 Posts
Discussion Starter #1
IS THERE A TRICK IM HAVING TROUBLE GETTING THE ecm and tcu connector plugs disconnected. i mean these are stout not even moving, and yes i pulled back the lock...
 

·
sensual nonconsensual
TrailblazerSS
Joined
·
57 Posts
.

wiggle and jiggle? At some point i stuck a flathead screwdriver on the side of the connector and twisted it to persuade it to break free. It was a real pain in the ass and ultimately just got angry and pulled on it with a good grip and it they came off.
 

·
Registered
2006 TrailblazerSS
Joined
·
122 Posts
Discussion Starter #3
yea i was about to try the screwdriver method. I dont wanna fuc the connector up though...there is only the one lock on the connectors correct?
 

·
sensual nonconsensual
TrailblazerSS
Joined
·
57 Posts
yea i was about to try the screwdriver method. I dont wanna fuc the connector up though...there is only the one lock on the connectors correct?
yeah just one lock, and pulling it back is suppossed to do the trick. You can tell when your prying too much and the connector is getting damaged though. I just found it helped to break whatever 5 year old seal mine had going on, then the good grip on it and muscle took care of the rest.
 

·
Registered
2006 TrailblazerSS
Joined
·
122 Posts
Discussion Starter #6
got em. thanks guys. lets see if she grew any legs...
 

·
Hooked on speed
06 Trailblazer SS
Joined
·
3,099 Posts
If you rotate the bails all the way around they actually lift the connectors off the modules. Then pull them free.
 

·
Premium Member
Bet you cant tell
Joined
·
6,480 Posts
when you release the lock - i grasp the connector and harness and with the other hand i hold the lock at the same time while wiggling the connector harness.

i get them to pop off in a sec everytime. they do loosen up after a few removals.
 
1 - 8 of 8 Posts
Top