Chevy Trailblazer SS Forum banner

1 - 8 of 8 Posts

·
The one and only JJ
Joined
·
14,071 Posts
Discussion Starter #1
Guys tonight i will post a graph of the re-tune i will be gettin done today at 11am. I had my SS tuned right away when i bought it (HP TUNED) but recently did a few simple mods and going for a retune.

Don't expect anything close to 500hp either, lol.
 

·
The one and only JJ
Joined
·
14,071 Posts
Discussion Starter #3
Kooks Headers 1 3/4 w/cats
SW Catback Exhaust
U/D Pulley
New CAI- designed by Leftcoast32
ls7 throttle body
GTO efans

simple tranny work- shift kit,2nd&4th gear servos,tranny cooler

For now thats all i did. So again don't even think i will close to 500, lol.
 

·
Premium Member
TBSS
Joined
·
1,279 Posts
Don't expect anything close to 500hp either, lol.
You must not be letting Vector re-tune it then, they would be able to hit that number for you no problem. I don't know if you heard, they won this award for being the best tuner ever or something like that...so clearly they are the best!
 

·
The one and only JJ
Joined
·
14,071 Posts
Discussion Starter #5
fukk them ****!!!!

Well guys i went to re-tune my SS and its having a few issues i need to figure out. First is my tuner cant even get it to dyno the way it should be. Hes thinking might be tranny, but i need to figure out exactly whats up with it. Its not dynoing in 3rd like it should with mods i have done to it. Also the PRICKS who did my mods didn't wire my GTO efans properly as only one is coming on instead of 2, blah blah. So with that said this will be continued!! I mean it drives great, blasts out of hole and with the shift kit it chirps, lol but bottom line is something is not right somewhere.
 

·
Registered
06 TBSS 2WD
Joined
·
346 Posts
fukk them ****!!!!

Well guys i went to re-tune my SS and its having a few issues i need to figure out. First is my tuner cant even get it to dyno the way it should be. Hes thinking might be tranny, but i need to figure out exactly whats up with it. Its not dynoing in 3rd like it should with mods i have done to it. Also the PRICKS who did my mods didn't wire my GTO efans properly as only one is coming on instead of 2, blah blah. So with that said this will be continued!! I mean it drives great, blasts out of hole and with the shift kit it chirps, lol but bottom line is something is not right somewhere.
I don't think it would be anything with the tranny is it runs fine on the street. Is it shifting down to second during the dyno? If so, he needs to get to about 80 before he hits it or it will downshift.
 

·
The one and only JJ
Joined
·
14,071 Posts
Discussion Starter #7
man i don't know what went wrong when i went to dyno it! Hell with it i don't need #'s i just know it drives fine on the street. Im afraid i dyno it again the engine will blow, hell he had it up to 125mph, lol.
 

·
Premium Member
2007 AWD 3SS
Joined
·
8,588 Posts
Heck, I did 125 MPH to run circles around a rumble bee...did it twice, once from about 80 and then again after we kept going. I don't think 125 will hurt anything.
 
1 - 8 of 8 Posts
Top