Chevy Trailblazer SS Forum banner
1 - 9 of 9 Posts

·
Registered
'06 TrailblazerSS
Joined
·
926 Posts
Discussion Starter · #1 ·
This happened last winter and never happened again until this week and it's happened twice. And body else have this happen and know how to fix it?
 

·
Registered
'06 TrailblazerSS
Joined
·
926 Posts
Discussion Starter · #2 ·
The only thing that's cosistant is 17" rims??
 

·
Registered
TrailblazerSS
Joined
·
533 Posts
Mine does this all the time but I think its because i cant keep my foo:biggrin2:eek:t off the pedal.
 

·
Premium Member
2007 AWD 3SS
Joined
·
8,588 Posts
If it's 2007, its common. The throttle is not sticking, it is a PCM glitch that GM says doesnt exist. It happenned to me a few times (but never when I wanted it to) and caused a few unwanted all wheel burnouts. I only wish I could make the motor run that way when I wanted it too!

The only way I have found to fix it is to use HPT to tune it and apply the TCS patches and that actually works.
 

·
Old but not Dead Yet!
TrailblazerSS
Joined
·
9,572 Posts
I think BBA probably has the right fix. BTW I have a funny story on this when I had my Roush F-150, the linkage froze up (yes it gets cold sometimes in SC) and it stuck WOT and I went sideways out into the highway until I straightened it up and then Cut the Damn thing OFF! It scared my Mule! Plus a County Mounty was behind me! /jerk
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top