Chevy Trailblazer SS Forum banner

1 - 20 of 22 Posts

·
Registered
Black '06 2WD
Joined
·
172 Posts
Discussion Starter #1
Jumped in the truck to head to work, started fine. Drove it just over a half mile to get gas. Shut it off, put 20 bucks in. Get back in to start it and it just clicks. Not your typical "click click click". It just clicks once. All lights, radio an sub come on. Battery gauge is around 11-12v. Probably just the battery since the starter does click, right?

Sorry if this is in the wrong section. I just wanted more people to see the question sooner. It's my only daily driver so I'm relying on parents vehicles until the SS is fixed.
 

·
PING-pong
TrailblazerSS
Joined
·
490 Posts
Either that or Ign. switch
 

·
Premium Member
07 TrailblazerSS Imp
Joined
·
9,386 Posts
Jumped in the truck to head to work, started fine. Drove it just over a half mile to get gas. Shut it off, put 20 bucks in. Get back in to start it and it just clicks. Not your typical "click click click". It just clicks once. All lights, radio an sub come on. Battery gauge is around 11-12v. Probably just the battery since the starter does click, right?

Sorry if this is in the wrong section. I just wanted more people to see the question sooner. It's my only daily driver so I'm relying on parents vehicles until the SS is fixed.
Probably ignition switch, IMO.
 

·
Registered
Black '06 2WD
Joined
·
172 Posts
Discussion Starter #6
Well, I'm going to take the starter off and get it tested.

Where is the ignition switch located just in case?
 

·
Moderator
Trailblazer SS
Joined
·
15,616 Posts
Just get a remote start lol
 

·
Registered
Joined
·
210 Posts
Had the same problem not to long ago, it turned out to be the starter.
I also had the same issue.

Be advised....the Starter is covered under the 5 year 100k mile Drivetrain Warranty!!!!!!
 

·
Registered
Black '06 2WD
Joined
·
172 Posts
Discussion Starter #10
I'm the 2nd owner though. Truck is an 06 with 76,000 miles.
 

·
Registered
07' TrailblazerSS
Joined
·
279 Posts
I'm having same problem but it starts after lights headunit and all come on. Ing. Switch battery or starter?
 

·
Iam sofa king we todd did
tbss
Joined
·
1,145 Posts
Check the batt connection also if you haven't done so already. I have had that happen to me.:doh:
 

·
Premium Member
07 TrailblazerSS Imp
Joined
·
9,386 Posts
Well, I'm going to take the starter off and get it tested.

Where is the ignition switch located just in case?
Its directly under the key insert area. The lower cover on the steering column comes off and you can see it-a small vertical retangular box. It takes a small prod/screwdriver pushed into the two holes on right side to release it downwards....then you can unplug it. It has 5 contacts for different accessories control, ign, starter etc. These contacts get corroded over time. The switch is not that much at O'Riellys $20 something with lifetime warranty.
 

·
Registered
Black '06 2WD
Joined
·
172 Posts
Discussion Starter #16
The starter looks like a royal PITA to get to. Are the two small bolts visible from underneath by the bell housing the only ones holding it on?
 

·
Registered
Black '06 2WD
Joined
·
172 Posts
Discussion Starter #18
Checked all battery and major power connections, all of them are tight. Started acts like it engages but once it does it quits. I ran to oreillys and they had to order the ignition switch. It'll be here tomorrow. Im going to give that a try and if that doesnt work, it's off to the mechanic.

Just odd. All dash lights work, turn the key and it clicks, all warning lights shut off and it acts as if the truck started fine. Radio and headlights stay on the entire time. So I'm hoping it's just the switch.
 

·
Registered
Black '06 2WD
Joined
·
172 Posts
Discussion Starter #19
Well, put the ignition switch in and it still clicks once. Looks like it's off to the shop it goes! :dunno:
 
1 - 20 of 22 Posts
Top