Chevy Trailblazer SS Forum banner

1 - 10 of 10 Posts

·
Registered
TrailblazerSS
Joined
·
12 Posts
Discussion Starter #1
The traction control keeps going off in my 2007 AWD, it goes off sometimes when accelerating from a stop. I brought it to a local repair shop and there was a code for rear ABS sensors, so I had them replaced. Still have the same problem. I have gone back to the shop every week for 4 weeks to see if there are any new code showing up, so far nothing. I replaced the steering wheel sensor 5 days ago (with a GM sensor) and still the same problem. Any idea's?
Thanks, Jim.
 

·
Registered
2008 TrailblazerSS
Joined
·
986 Posts
Wheel hubs. Replace them all


Sent from my iPhone using Tapatalk
 

·
Registered
07 tbss awd
Joined
·
11 Posts
The traction control keeps going off in my 2007 AWD, it goes off sometimes when accelerating from a stop. I brought it to a local repair shop and there was a code for rear ABS sensors, so I had them replaced. Still have the same problem. I have gone back to the shop every week for 4 weeks to see if there are any new code showing up, so far nothing. I replaced the steering wheel sensor 5 days ago (with a GM sensor) and still the same problem. Any idea's?
Thanks, Jim.
I have been having the same problem. Has the abs activated while driving? Not sure if your the orignal owner but there are several software updates for the ebcm and other modules. I contacted the dealer yesterday and was told my 07 ss has not had any of the updates since new. Also check the ground wire to the ebcm. If you look at the frame underneath the driver door you'll see it to the left!
 

·
Lighter-than-you
TrailblazerSS
Joined
·
331 Posts
delete, delete, delete!
 

·
Registered
TrailblazerSS
Joined
·
12 Posts
Discussion Starter #6
I have been having the same problem. Has the abs activated while driving? Not sure if your the orignal owner but there are several software updates for the ebcm and other modules. I contacted the dealer yesterday and was told my 07 ss has not had any of the updates since new. Also check the ground wire to the ebcm. If you look at the frame underneath the driver door you'll see it to the left!
I'm not the original owner, I'm not sure if it has had the software updates. The problem I'm having is when I come to a stop, then accelerate, as soon as I give it gas the stabilitrak goes off, but not all of the time. I can turn it off, but I can still hear the ABS going off sometimes. I have already replaced the rear ABS sensors and the steering wheel sensor, I would hate to pay to have the front hubs replaced with new sensors and find out that I still have the same problem.
Thanks, Jim.
 

·
Registered
TrailblazerSS
Joined
·
12 Posts
Discussion Starter #7
I have had the SS for 11 months and this problem just started, I can't see how it would be a software issue.
 

·
Registered
2007 3SS AWD
Joined
·
62 Posts
The traction control keeps going off in my 2007 AWD, it goes off sometimes when accelerating from a stop. I brought it to a local repair shop and there was a code for rear ABS sensors, so I had them replaced. Still have the same problem. I have gone back to the shop every week for 4 weeks to see if there are any new code showing up, so far nothing. I replaced the steering wheel sensor 5 days ago (with a GM sensor) and still the same problem. Any idea's?
Thanks, Jim.
Got brake fluid?
 

·
Registered
TrailblazerSS
Joined
·
12 Posts
Discussion Starter #10
I had both front hubs replaced yesterday and so far so good. Thanks for everybody's help!
 
1 - 10 of 10 Posts
Top