Chevy Trailblazer SS Forum banner

1 - 9 of 9 Posts

·
Premium Member
TBSS
Joined
·
1,279 Posts
Discussion Starter #1
Thanks for the section Tony.

I woke up yesterday morning and when I got in my truck to go to breakfast I noticed the check engine light was on. Not thinking anything of it, I stopped to get gas, and when I went to start it nothing happened (no clicking or anything). I tried on and off a couple times and finally it started. I then went to breakfast where it did the same thing afterwards.

On the way home I called onstar to see what the CEL was, they said it was showing a malfunction in the starting system...thanks. Any ideas on exactly what the problem might be?
 

·
Registered
Joined
·
308 Posts
Surprised to see that it will start at all. My 07 Tahoe did the same thing and I had to get it towed to the dealer. Fried battery. the clicking you stated sounds like a battery issue, but I've never seen them start up if they are bad.
 

·
Some PCM of NC bolton's
Joined
·
9,639 Posts
:iamwithstupid:
When I get ome 2night i'll look and see if they put a tsb on the invoice when they replaced mine
 

·
Premium Member
2006 TBSS AWD Modded
Joined
·
13,311 Posts

·
Premium Member
Joined
·
1,269 Posts

·
Premium Member
TBSS
Joined
·
1,279 Posts
Discussion Starter #9
no TSB on my invoice sorry
No worries...thanks for checking. The truck is in the shop and I'm waiting to hear back from my service guy. I'm out of town 'til tomorrow, so hopefully it's ready when i get home. I'll let you all know.
 
1 - 9 of 9 Posts
Top