Chevy Trailblazer SS Forum banner
1 - 20 of 36 Posts

·
Registered
TrailblazerSS
Joined
·
917 Posts
Discussion Starter · #1 ·
so does anyone know what's causing our batteries to drain out so quick?
my truck was sitting there for 3 weeks and when i went to turn it over.
i've got an amp with a subwoofer in, and i also just installed a power inverter and a dvd player. the inverter is turned off and i hardly use the dvd player, but yet my battery drained out. i just put a new autozone gold in there, but now i'm thinking would it be better if i go with optima? i'm still under the new battery warranty, so i'm gonna go change that. any opinions? thanks.
 

·
The one and only JJ
Joined
·
14,071 Posts
This is a chronic issue with the SS and yes DOwork (member on here has info). I actually took my SS into dealership the other day to figure whats going on and will have feedback within a few days I'm guessing. An Optima wont help you as i went this route and it still does same stuff. I actually just changed to Optima because my STOCK BATTERY FINALLY TOOK A DUMP. I do have a high-end Alarm that lights up interior like a gay disco bar when its armed, but at same time i rarely drive my ss so i dont know whats going on. Theres a bulletin you can tell SERVICE tech about, but other than that i dont know what to tell you. Ive heard anything from replacing OnSTAR unit to taking out fuse for rear hatch. I will find out soon and i will tell you what they feel my issue is.
 

·
Premium Member
'08 SRX V-6 AWD
Joined
·
2,767 Posts
How many people with 1SSs have this problem? the 3SS has so many bells and whistles, it would be a crap shoot to figure out which are keeping their batteries' sphincter open.
The only whistle my '07 1SS has is when I provide it, myself and I have yet to have mine fail to start in 45,000 miles.
 

·
Premium Member
'07 awd
Joined
·
2,422 Posts
I've seen the battery run down issue on other GM vehicles that have an aftermarket electronic device (of any kind) installed. On these vehicles, normally all the control modules on the car/suv go into a sleep mode so many minutes after shutting the vehicle off. This happened to prevent excessive battery draw. The problem ended up being that this electronic device (remote start, stereo stuff...) wired into the vehicle would not let the modules go to sleep, never really let them think the car was turned off. This didn't happen on any TBSS's that I saw, but I wouldn't rule it out. The vehicles it did happen to were a bit more modern, like an 07-08 Tahoes and an 06 Impala SS, so it may not apply to the TBSS anyway. Just something I've seen.
 

·
Registered
TrailblazerSS
Joined
·
936 Posts
My 08 would not crank after sitting for 2-3 weeks in the garage. Still cold inside garage, but now have a battery tender and it cranks great now.
 

·
The one and only JJ
Joined
·
14,071 Posts
I hope the dealership doesnt call me n say its my aftermarket alarm because ive had it since 07 and only recent in last 2-3 months have i noticed battery drainage.

DoWORK, i WILL MAKE SURE DEALER HEARS THIS BUT I'm sure they just pull up bulletins and rule everything out !!!! Send it over though please.....
 

·
Premium Member
TrailblazerSS
Joined
·
1,842 Posts
My 08 would not crank after sitting for 2-3 weeks in the garage. Still cold inside garage, but now have a battery tender and it cranks great now.
What one do you have? I'm going to have to get something like this. I'm on the road 21 straight days a month. I need to get one before i kill my battery for good.
 

·
Registered
TrailblazerSS
Joined
·
917 Posts
Discussion Starter · #16 ·
This is a chronic issue with the SS and yes DOwork (member on here has info). I actually took my SS into dealership the other day to figure whats going on and will have feedback within a few days I'm guessing. An Optima wont help you as i went this route and it still does same stuff. I actually just changed to Optima because my STOCK BATTERY FINALLY TOOK A DUMP. I do have a high-end Alarm that lights up interior like a gay disco bar when its armed, but at same time i rarely drive my ss so i dont know whats going on. Theres a bulletin you can tell SERVICE tech about, but other than that i dont know what to tell you. Ive heard anything from replacing OnSTAR unit to taking out fuse for rear hatch. I will find out soon and i will tell you what they feel my issue is.
please keep me informed on your situation. i don't have an aftermarket alarm, but i've but in the JL stealthbox with 500w amp, also i just put in a power inverter but it's not turned on. i've also got an ipod adaptor, pac Gm adaptor to turn stock navi into monitor and i just installed a DVD player for the front. not sure if all this is causing it or not. i've already done the Big 3 upgrade from PCM. i just switched up for a red top Optima, i'll be putting that in tomorrow. hope it's not a huge problem.
 

·
Registered
TrailblazerSS
Joined
·
917 Posts
Discussion Starter · #17 ·
I've seen the battery run down issue on other GM vehicles that have an aftermarket electronic device (of any kind) installed. On these vehicles, normally all the control modules on the car/suv go into a sleep mode so many minutes after shutting the vehicle off. This happened to prevent excessive battery draw. The problem ended up being that this electronic device (remote start, stereo stuff...) wired into the vehicle would not let the modules go to sleep, never really let them think the car was turned off. This didn't happen on any TBSS's that I saw, but I wouldn't rule it out. The vehicles it did happen to were a bit more modern, like an 07-08 Tahoes and an 06 Impala SS, so it may not apply to the TBSS anyway. Just something I've seen.
the amp that i installed is a Rockford punch amp and has a seperate knob for bass boost. the red light on the knob does shut off after a couple of minutes so i'm pretty sure, or atleast hoping the car does go into sleep mode.
 

·
Registered
TrailblazerSS
Joined
·
917 Posts
Discussion Starter · #18 ·
Its the VCI hanging up and causing onstar to stay powered.....



BTW JJ, sorry, I forgot to send you that email :(
is the email concerning the VCI hanging up and causing the drainage? if so, can you email me a copy also just incase i need to bring the truck into the dealership incause the optima doesn't help. i'm gonna try to atleast drive the truck once a week from now on. it usually sits there for 2-3 weeks at a time also. i work everyday so i'm constantly driving my Accord to work. 7 days a week is rough.
 

·
Premium Member
06 & 08 TBSS
Joined
·
2,916 Posts
is the email concerning the VCI hanging up and causing the drainage? if so, can you email me a copy also just incase i need to bring the truck into the dealership incause the optima doesn't help. i'm gonna try to atleast drive the truck once a week from now on. it usually sits there for 2-3 weeks at a time also. i work everyday so i'm constantly driving my Accord to work. 7 days a week is rough.
If its the VCI buying an optima won't do shit. Just lighten your wallet.
 

·
Registered
TrailblazerSS
Joined
·
936 Posts
Kyle got the "Battery Tender" model with the quick disconnect and cigarette lighter plug also. The cigarette plug does not charge as strong as the other plug under hood but works freakin great. Plug under hood has cover to keep out whatever while driving. Paid 120.00 from autogeek.net they had it cheaper than direct from the manufacturer, go figure. The underhood plug is 5amps and the cigarette is 2.5 or 3 I think.

 
1 - 20 of 36 Posts
Top