Chevy Trailblazer SS Forum banner
1 - 12 of 12 Posts

·
Registered
2007 2WD
Joined
·
416 Posts
Discussion Starter · #1 ·
I've been trying to find answers... so here it is:

TBSS in park. It starts, but when I push brake, theres no "click" to disengage the shifter button. I checked the linkage and cable. No sign of the linkages or the cable being loose/broken. Brake lights turn on when pressing brake pedal. Fuse 25 seems good.

I am aware of the override button in the console, and when I press that, the shifter can then move...

I have no other ideas as to what is going on... Any help here? Thx !!
 

·
Premium Member
'08 TrailblazerSS
Joined
·
2,995 Posts
At the underhood fuse block, check fuse #27, BCK/UP, 15A
 

·
Premium Member
'08 TrailblazerSS
Joined
·
2,995 Posts
do you have a volt meter?
 

·
Registered
TrailblazerSS
Joined
·
260 Posts
It’s probably the interlock in the center console. I’m dealing with something similar. If I smack the top of the shifter it will work. Mines pretty intermittent
 

·
Premium Member
07 TrailblazerSS Imp
Joined
·
9,440 Posts
Its prob the solenoid down in the console isnt being activated? Thats not a common thing. It is connected to the solenoid up in the steering column by the ign switch.
 

·
Registered
2007 2WD
Joined
·
416 Posts
Discussion Starter · #8 ·
Alright, so I drove it today... when I parked, I totally forgot I'd have to put it in Park in order to get the key out. LoL.. so yeah Im guessing it has something to do with the solenoid since it doesnt allow me to remove the key until it shifts into park... smh... I cant find anything on youtube on how to fix/replace it so it looks like Ima bring it to a shop or the dealer... damn
 

·
Registered
TrailblazerSS
Joined
·
6 Posts
Alright, so I drove it today... when I parked, I totally forgot I'd have to put it in Park in order to get the key out. LoL.. so yeah Im guessing it has something to do with the solenoid since it doesnt allow me to remove the key until it shifts into park... smh... I cant find anything on youtube on how to fix/replace it so it looks like Ima bring it to a shop or the dealer... damn
Inspect the bushing on the cable on your shifter - it is on the left side of the transmission. Slide under and take a look.
 

·
Registered
TrailblazerSS
Joined
·
114 Posts
Inspect the bushing on the cable on your shifter - it is on the left side of the transmission. Slide under and take a look.
Don't bother.. It's the solenoid on the shifter assembly in the console . Take your shifter off, and the top plate of the console and you can see it in there. See if it's getting voltage.. . If you don't have a meter, use a lightbulb... Or get a voltage tester from any auto parts store... They are cheap.

If the solenoid is bad, and you either don't rant to or can't replace it, disable it... Ie remove it.... And you'll be good to go. You will be able to move the shifter when the engine is off and key off... Without touching the brake.. . But que sera
 

·
Registered
2007 2WD
Joined
·
416 Posts
Discussion Starter · #11 ·
Don't bother.. It's the solenoid on the shifter assembly in the console . Take your shifter off, and the top plate of the console and you can see it in there. See if it's getting voltage.. . If you don't have a meter, use a lightbulb... Or get a voltage tester from any auto parts store... They are cheap.

If the solenoid is bad, and you either don't rant to or can't replace it, disable it... Ie remove it.... And you'll be good to go. You will be able to move the shifter when the engine is off and key off... Without touching the brake.. . But que sera
ooh... how do I disable it?
 

·
Registered
2007 2WD
Joined
·
416 Posts
Discussion Starter · #12 ·
I tried searching how to disable... cant find anything?
 
1 - 12 of 12 Posts
Top