Chevy Trailblazer SS Forum banner
1 - 6 of 6 Posts

·
Registered
TrailblazerSS
Joined
·
43 Posts
Discussion Starter · #1 ·
Is this just a coincidence?? I was doing the DRL killer with the relay and after I was done, I moved the truck and noticed the truck was idling rough. Looking at the wiring on the 2 plugs at the BCM it doesn't look like there is anything that would cause the rough idle to happen after doing this. The truck is under warranty but wondering what could have happened. Any suggestions?
 

·
Registered
TrailblazerSS
Joined
·
43 Posts
Discussion Starter · #2 ·
Brought it to the dealer since its under warranty and its a bad spark plug. Bad thing about that is the previous owner changed the plugs to pulstar plugs which will not be covered under warranty. That blows!
 

·
Registered
TrailblazerSS
Joined
·
43 Posts
Discussion Starter · #3 ·
I guess I'm talking to myself at this point but I talk to myself all time anyway. I actually knew a tech at the dealership that got me new plugs and changed them there and charged me $140. Pretty pleased that he looked out for me like that. To top it off he even drove it to my house which save me a 60 mile trip there and back.
 

·
Registered
08 RJT 3SS
Joined
·
69 Posts
TR-55's work well on these trucks? Because im at 29k miles now and my truck shakes at idle. not like my cammed camaro does, but maybe i got a bad plug too. Ive got a drawer full of tr-55's. i always thought it was due to the LS2's nature. I'm waiting for my longtubes and tune so i guess i'll swap out plugs anyways.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top