Chevy Trailblazer SS Forum banner
1 - 15 of 15 Posts

·
Registered
TrailblazerSS
Joined
·
889 Posts
Discussion Starter · #1 ·
I just installed and fired up my procharger set-up and above 3k rpms it goes into limp mode and throws the following codes:
P2101: throttle actuator control circuit
P1516: Unknown
P0175: System too Rich Bank 2
P0172: System too Rich Bank 1
Background:
This is a D1SC with 60# injectors and a start-up tune from PCMforless.
The throttle body is a cnc ported unit from Norris Motorsports.
Before hooking up the procharger, I was moving the truck in/out my driveway with the LS7 MAF pipe and a filter and I didn't have any CELs, so I'm assuming it's not the throttle body itself.
Any suggestions......?
 

·
Premium Member
TrailBlazer SS AWD
Joined
·
4,063 Posts

·
TT AWD TBSS Jeep
TT AWD SS Pwrd Jeep
Joined
·
5,825 Posts
I had the 1516 and the 2101 after porting my throttle body also, and had to adjust the throttle blade up. It even set the reduced power mode, and ran like crap til I adjusted the throttle blade. Prob what those two codes are from, and the rich is the tune.
 

·
Registered
TrailblazerSS
Joined
·
889 Posts
Discussion Starter · #8 ·
I had the 1516 and the 2101 after porting my throttle body also, and had to adjust the throttle blade up. It even set the reduced power mode, and ran like crap til I adjusted the throttle blade. Prob what those two codes are from, and the rich is the tune.
Sounds like my problem, thanks for the info!
 

·
Premium Member
2007 TBSS AWD
Joined
·
31,504 Posts
I had the 1516 and the 2101 after porting my throttle body also, and had to adjust the throttle blade up. It even set the reduced power mode, and ran like crap til I adjusted the throttle blade. Prob what those two codes are from, and the rich is the tune.
Very important to get the throttle blade in the sweet spot after removing it for porting.
 

·
Registered
TrailblazerSS
Joined
·
889 Posts
Discussion Starter · #11 ·
UPDATE
Turns out it was the cnc ported throttle body. Swapped in an LS3 tb and it now works great. Spoke to Mike @ Norris Motorsports and they are sending me a replacement (good customer service) not sure if I'm gonna use it or just keep the LS3 tb, b/c it's working great so far. Thanks for the ideas guys, including Alvin @ PCMforless, who nailed it in his first reply and told me it was the tb.
 

·
Premium Member
2007 TBSS AWD
Joined
·
31,504 Posts
UPDATE
Turns out it was the cnc ported throttle body. Swapped in an LS3 tb and it now works great. Spoke to Mike @ Norris Motorsports and they are sending me a replacement (good customer service) not sure if I'm gonna use it or just keep the LS3 tb, b/c it's working great so far. Thanks for the ideas guys, including Alvin @ PCMforless, who nailed it in his first reply and told me it was the tb.
You have to be careful with ported TBs. This is why I usually port my own by hand.
 

·
Registered
TrailblazerSS
Joined
·
889 Posts
Discussion Starter · #13 ·
You have to be careful with ported TBs. This is why I usually port my own by hand.
I had a hand ported one before with zero issues, I should have kept it. Let me see how the replacement one they send measures up and if it doesn't I'll just keep the LS3 one and ask for a refund.
 

·
Premium Member
TrailBlazer SS AWD
Joined
·
4,063 Posts
I said it was the TB too. And I told you the LS3 would work. I'd keep the LS3 over the stock truck style TB.
 
1 - 15 of 15 Posts
Top