Chevy Trailblazer SS Forum banner

1 - 18 of 18 Posts

·
Premium Member
Joined
·
1,936 Posts
Discussion Starter #1
This is kind of a long story but basically last July (when I still lived in MI) I bought the TBSS, 3 weeks later it got broken into and the thieves stole the tires/rims, etc... I took it back to the dealership to have it fixed. They ordered new tires/rims and fixed it up. 2 weeks later I got it back.

I immediately started getting the warning about the sensors on my dash so I took it back in. I went back and forth with the dealership a total of 4 visits (over a few weeks time) before the geniuses realized that they never put the pressure sensors in and it took them several visits to install them and get them working properly. On the 4th visit they refused to give me paperwork about it since they knew I could lemon law it at that point. That was finally resolved in September of last year.

Fast forward to this week (now I live in MD). Monday I had a really low tire pressure (26, I usually keep them at 35) on the Left Front. Looked like a leak so I stopped by National Tire & Battery on the way to work thinking I had run over a nail or something. They couldn't find a leak, said to bring it back if it got low again. Last night, it was low again (28) so I took it in this morning. They find that it was the bolt holding the pressure sensor on...it had come loose and was leaking from there. :death: They were cool though and never charged me a dime either visit.

Now I'm pissed!

I called GM saying I could lemon law this POS but I'd be happy if they just replaced all 4 tires & sensors since the first dealership fucked it up. GM says contact the local MD dealership and the original MI dealership and have the MD one look at the leak. I explained that the leak was fixed this morning so there isn't one anymore. This concept is apparently lost on GM. I said I have paperwork that explains where the leak came from. They repeat, have the MD dealership look at the leak. After explaining several times that there is NO MORE LEAK now. They still want me to contact the MD dealership. So I did and I have to go there at 2pm today. They're super nice and being very cool.

I contacted the old dealership in MI and the service manager (douche bag) :fist:gets an attitude and is rude. But I refuse to back down that his service dept fucked up. So he finally says that if there is any cost to have the MD dealership fax it over to him and they'll look at it. ugggghhhh!!!!:biteme:

I'm SO pissed!

So now I have to go in at 2pm and see what they can do, if anything. AGGGGHHHH!!!!
 

·
Premium Member
Joined
·
1,936 Posts
Discussion Starter #3
Thanks. Yeah it sucks. It's such a small thing but it's been such a big pain. I talked to the dealership manager here in MD and he basically doesn't want to get involved. I don't blame him. It sucks for me though. That dealership in MI basically just got lucky because I can't do anything since I'm out of state now.

Oh well. There's nothing more I can do at this point but hope no more problems arise. What a pain in the ass! grrr!!
 

·
Premium Member
Joined
·
8,576 Posts
Thanks. Yeah it sucks. It's such a small thing but it's been such a big pain. I talked to the dealership manager here in MD and he basically doesn't want to get involved. I don't blame him. It sucks for me though. That dealership in MI basically just got lucky because I can't do anything since I'm out of state now.

Oh well. There's nothing more I can do at this point but hope no more problems arise. What a pain in the ass! grrr!!
Understood! You could always add a MagnaCharger and forget about the tire sensors.

:ss-smiley:
 

·
The one and only JJ
Joined
·
14,071 Posts
Jus buy new sensors on Ebay and take it to a reputable rim shop in your area.
 

·
Premium Member
06 AWD TBSS
Joined
·
14,992 Posts
How the hell we go from these sensors to tits? lol

My chit comes on every 8 miles. Fukin sucks
 

·
Premium Member
06 AWD TBSS
Joined
·
14,992 Posts
Because JJ found this thread! lol


Your monitor goes off that often?! Dude, that ain't right.
You know...your right. lol. He DID find this thread. hahaha.

I guess I shouldnt say EVERY 8 miles. But whenever the trucks off then back on. That 8th mile it comes back on. They are trying to blame it on my stereo and my backup camera. I still need to go and see wtf is up with this. I've gotten use to it, but still. After the first time it goes off. It'll come on a couple more times then it'll totally quit. But thing is, my tires are fine. I've gotten all new sensors. They still do it.
 

·
Premium Member
Joined
·
1,936 Posts
Discussion Starter #13
I guess I shouldnt say EVERY 8 miles. But whenever the trucks off then back on. That 8th mile it comes back on. They are trying to blame it on my stereo and my backup camera. I still need to go and see wtf is up with this. I've gotten use to it, but still. After the first time it goes off. It'll come on a couple more times then it'll totally quit. But thing is, my tires are fine. I've gotten all new sensors. They still do it.
That really sucks! Did they try to reprogram the sensors? Or are they just saying you f'ed up a wire somewhere? That warning thing is annoying as hell.
 

·
Premium Member
06 AWD TBSS
Joined
·
14,992 Posts
That really sucks! Did they try to reprogram the sensors? Or are they just saying you f'ed up a wire somewhere? That warning thing is annoying as hell.
Nah, the didnt say it was me. But the tech wanted me to return it all back to stock then see if it works then. He didnt care, but he said if the rep wanted more intel on it and seen the mods that he prolly wouldnt take care of the problem (I dont know if thats BS or not, cant call it). I havent had a day to get into the stereo shop for them to do this. Which is going to cost me money.

They were thinking it was some modulator in the back hatch or something. And with my backup camera back there could be screwing something up. They put a new one in and it still does it. I jus wonder wtf does my camera have to do with the sensors. They told me it goes threw there somehow or another. Like I said, I cant call it. Sounds like BS. I just been dealing with it, but still have to take it in.
 

·
Premium Member
Joined
·
2,066 Posts
i say fuck it, wait as long as you can and lemon law that shit, Hopefully all 07's are gone and you can get an 08 :) that would be sick. And hopefully that asshole at the dealership in MD gets fired cause they gotta get you a new SS :) goodluck
 
1 - 18 of 18 Posts
Top