Chevy Trailblazer SS Forum banner

1 - 13 of 13 Posts

·
Premium Member
TrailblazerSS
Joined
·
7,324 Posts
Discussion Starter #1
when i got out of work tonight i fired up the ss and heard a rattle right when i fired it up! i revved it a little, and the rattle was still there, but only when i revved it! not at idle or gradual rpm increase! then i went to leave and as i went forward it sounded like an exhaust tick but went away as the engine warmed up! my CEL isn't on! and it seems to be running the same! 52,000 miles! any suggestions?
 

·
Premium Member
TrailblazerSS
Joined
·
2,655 Posts
Doubt it's a cat if performance hasn't changed or you can't smell it. I would crawl under and look for anything loose near the exhaust, maybe tap muffler and the cats with a hammer to see if you can hear anything rattling.
 

·
Registered
Joined
·
66 Posts
Passenger side cat was the culprit when I had this problem. It sounded like bolts in a coffee can that got louder at higher RPMs.
 

·
Call da amber lamps
TrailblazerSS
Joined
·
966 Posts
Take a rubber mallet and tap the cats. You should be able to hear it if it's one of the cats. You're covered under emmissions warranty still.
 

·
Premium Member
TrailBlazer SS
Joined
·
2,091 Posts
I just had the same problem...took it to the dealer and the cats needed replaced
 

·
Premium Member
TrailblazerSS
Joined
·
7,324 Posts
Discussion Starter #7
i guess i should've posted that i got it fixed! it was my drivers side cat! i drove it about 200 more miles and the damn catalyst turned sideways inside, and sent the ss into limp mode! i now have the magnaflow catted y pipe! all is good!
 

·
Premium Member
TrailblazerSS
Joined
·
7,324 Posts
Discussion Starter #8
Take a rubber mallet and tap the cats. You should be able to hear it if it's one of the cats. You're covered under emmissions warranty still.
btw the rubber mallet trick didnt work for me!
 

·
Registered
TrailblazerSS
Joined
·
535 Posts
i guess i should've posted that i got it fixed! it was my drivers side cat! i drove it about 200 more miles and the damn catalyst turned sideways inside, and sent the ss into limp mode! i now have the magnaflow catted y pipe! all is good!
How is all good when it throws a code?
 

·
Premium Member
TrailblazerSS
Joined
·
2,655 Posts
How much did the Magnaflow pipe run you? I looked on their site and kinda jaw dropped at the MSRP. Are they high flows or OEM replacement?
 

·
Premium Member
TrailblazerSS
Joined
·
7,324 Posts
Discussion Starter #12 (Edited)
How is all good when it throws a code?
:fu: yes i do still get a CEL, im getting a catalyst efficiency below threshold on both banks! its happening because of the cats being HIGH FLOW and being UNTUNED!
 

·
Premium Member
TrailblazerSS
Joined
·
7,324 Posts
Discussion Starter #13
How much did the Magnaflow pipe run you? I looked on their site and kinda jaw dropped at the MSRP. Are they high flows or OEM replacement?
$550 from summit! they're high flows!
 
1 - 13 of 13 Posts
Top