Chevy Trailblazer SS Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
For the past 6 months my tbss has had in between 25 and 30 psi of oil pressure at hot idle. It has 40 psi on cold start up. Driving it has a little over 40 and on the highway it has right under 40. Is it normal?
 

·
Registered
Joined
·
25 Posts
My best guess is the oil pump & spring could be worn if the pressure readings are correct. IMO the stock gauge isn’t a true reading (more of an “indicator”). Stock oil pump have a stamped steel backing plate while aftermarket pumps, such as melling have a cast iron one (stiffer).
 

·
Registered
2008 TBSS Red Jewel RWD
Joined
·
952 Posts
Normal

Sent from my moto g play (2021) using Tapatalk
 

·
Registered
TrailblazerSS
Joined
·
15 Posts
Nothing wrong with those numbers. Now if you drop down to low teens at hot idle then start inspecting thing's. Everyone said it was fine and normal on mine and when I wasn't satisfied I pulled the oil pan and it was full of bearing material.

#2 rod had spun a bearing and trashed the rod and scored the crank. Never knocked just low oil pressure at idle, still had over 30 at 2k while driving.
 

·
Registered
TrailblazerSS
Joined
·
3 Posts
When I'm running my torgue app on my phone my trailblazer is running hot at idle between 32-36. When driving it will go up to 42-44. The gauge on my dash will just go below 40 when hot and will be at 40 driving when hot. That's a normal range by sounds of what your saying.
 
1 - 9 of 9 Posts
Top