Chevy Trailblazer SS Forum banner
1 - 19 of 19 Posts

·
Premium Member
TrailblazerSS
Joined
·
2,747 Posts
Discussion Starter · #1 ·
So I installed my HIDs while I was swapping motors (why not the front is off right).

My fogs work fine, but my headlights wont come on at all.

I have not installed the jettt harness yet, but figured the headlights should come on regardless.

Any thoughts?

Thanks,
Jeremiah
 

·
Premium Member
08 TBSS
Joined
·
5,858 Posts
Could be the ground.. Some of these kits need you to swap the 2 plugs that are really small and kind of round. A bad ground will cause them to flicker on real quick then right off.
 

·
Premium Member
Trailblazer SS
Joined
·
5,558 Posts
Try flip flopping the hid plug into your factory light plug sounds like a polarity issue.
:iamwithstupid:

It is 180 degrees you can only go one way or flip it upside down to do the other. If the polarity isn't correct they won't fire.
 

·
Premium Member
TrailblazerSS
Joined
·
2,655 Posts
+3 on the plug.
 

·
Premium Member
TrailblazerSS
Joined
·
2,747 Posts
Discussion Starter · #7 ·
I will check the polarity when I get home.

They only connect 1 way so I didn't check...another lesson learned! My fogs had to be "hard wired" and no issue, so it probably is polarity-I didn't think of that, as I "assumed" it was correct since they had the propper plugs.
 

·
Registered
TrailblazerSS
Joined
·
295 Posts
If its a DDM kit the bigger plug on the ballast can be plugged in either way, turn it around.

Im sure you have the red to red and the black to black on the actual bulb wiring.
 

·
Premium Member
'07 3SS AWD
Joined
·
1,841 Posts
I will check the polarity when I get home.

They only connect 1 way so I didn't check...another lesson learned! My fogs had to be "hard wired" and no issue, so it probably is polarity-I didn't think of that, as I "assumed" it was correct since they had the propper plugs.
How did you go about wiring your fogs? I'm going to put mine in next weekend.

Edit: And yeah, I made the mistake on that plug the first time as well. If you used a relay harness, check the ground as well.
 

·
Premium Member
TrailblazerSS
Joined
·
2,747 Posts
Discussion Starter · #10 ·
Its all good...just flipped the plug and viola HID headlights!

The fogs I just slid the pins into the stock harness and put lots of electrical tape around them. Some one had posted the plug PN somewhere, I may do that someday.
 

·
Premium Member
TrailblazerSS
Joined
·
2,655 Posts
Yeah DDM's little lock nub thing is opposite from our factory plug, but they work great. I put a thin zip tie between the wires on the plug and the other side of the ballast to make sure it doesn't come out.
 

·
Premium Member
TrailblazerSS
Joined
·
1,086 Posts
everyone has that problem with the ddm ballasts lol
I know I did with my DDM. I ended up oulling out the plugs from the DDM harnes and reversing the wires so everything locking in place like it was designed to. Worked great.
 

·
Registered
TrailblazerSS
Joined
·
295 Posts
The raptor kits from DDM have the plug-in on the ballast marked + and - so just make sure you put the plug to that so the red is + and black -.
 
1 - 19 of 19 Posts
Top