Chevy Trailblazer SS Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
Just picked it up this past Tuesday. Gave it the once over and changed oil. Came with 4 wheel brake job, new water pump and alternator and new tires. So far I’m loving this truck. Everything looks solid underneath, no leaks, no rot. Big miles but it is what it is. For 6500$ im not complaining.
102227
 

·
Registered
2008 TBSS Red Jewel RWD
Joined
·
812 Posts
Welcome to the forum. Do you have any plan to mod it or will it stay stock?

Sent from my moto z3 using Tapatalk
 

·
Registered
Joined
·
14 Posts
Discussion Starter #3
Welcome to the forum. Do you have any plan to mod it or will it stay stock?

Sent from my moto z3 using Tapatalk
Thanks! More than likely going to leave it stock because of the miles, however I will upgrade the suspension due to the factory parts being well past their prime. It has a magnaflow muffler which sounds perfect to me. There’s plenty of power for what I use it for but you know how that goes...
 

·
Registered
2008 TBSS Red Jewel RWD
Joined
·
812 Posts
If you use it for towing you should add an additional trans cooler and trans temp gauge.

Sent from my moto z3 using Tapatalk
 

·
Registered
Joined
·
14 Posts
Discussion Starter #6
If you use it for towing you should add an additional trans cooler and trans temp gauge.

Sent from my moto z3 using Tapatalk
appreciate the input, however I will not be towing with this truck. Strictly a grocery getter, take me snowboarding and hiking truck. Oh and take me to work.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #7
Welcome!

it looks lowered to me?
Thanks and yeah after I took that pic I thought the same thing but really, I don’t have anything to compare it too. The running boards might also give it the illusion of sitting a bit lower as well
 

·
Registered
TrailblazerSS
Joined
·
307 Posts
Yeah definitely do suspension, that front tire camber is gnarly.

Sent from my SM-G970U using Tapatalk
 

·
Registered
Joined
·
14 Posts
Discussion Starter #10
Yeah definitely do suspension, that front tire camber is gnarly.

Sent from my SM-G970U using Tapatalk
Already ordered a lot for the front. That pic however is misleading due to the uneven ground that it’s parked on. The wheels are not out of alignment. I’ll admit, it does look funky in that pic which made me go double check.
 

·
Registered
TrailblazerSS
Joined
·
307 Posts
Already ordered a lot for the front. That pic however is misleading due to the uneven ground that it’s parked on. The wheels are not out of alignment. I’ll admit, it does look funky in that pic which made me go double check.
Haha, I understand.. sometimes mine will look the same. Thats good about the parts you ordered if you have any questions let me know. It's been awhile but I have completely rebuilt my front end, pretty much every component so I'll tap into the ol' mental for reference if need be. Good luck, im kinda digging the side steps. After I saw a pic I went and looked some up lol here's what mine looks like. Congrats and enjoy your's.


Sent from my SM-G970U using Tapatalk
 

·
Registered
Joined
·
14 Posts
Discussion Starter #12
Haha, I understand.. sometimes mine will look the same. Thats good about the parts you ordered if you have any questions let me know. It's been awhile but I have completely rebuilt my front end, pretty much every component so I'll tap into the ol' mental for reference if need be. Good luck, im kinda digging the side steps. After I saw a pic I went and looked some up lol here's what mine looks like. Congrats and enjoy your's.https://uploads.tapatalk-cdn.com/20210226/b24d264ba66d9a091e84c6b9a2bd51f7.jpg[/IM

Sent from my SM-G970U using Tapatalk
Haha, I understand.. sometimes mine will look the same. Thats good about the parts you ordered if you have any questions let me know. It's been awhile but I have completely rebuilt my front end, pretty much every component so I'll tap into the ol' mental for reference if need be. Good luck, im kinda digging the side steps. After I saw a pic I went and looked some up lol here's what mine looks like. Congrats and enjoy your's.https://uploads.tapatalk-cdn.com/20210226/b24d264ba66d9a091e84c6b9a2bd51f7.jpg
Sent from my SM-G970U using Tapatalk
[/QUOTE]
[QUOTE="Mjk716, post: 3649504, member: 73697"]
Already ordered a lot for the front. That pic however is misleading due to the uneven ground that it’s parked on. The wheels are not out of alignment. I’ll admit, it does look funky in that pic which made me go double check.
[/QUOTE]
[QUOTE="210troop, post: 3649506, member: 19720"]
Haha, I understand.. sometimes mine will look the same. Thats good about the parts you ordered if you have any questions let me know. It's been awhile but I have completely rebuilt my front end, pretty much every component so I'll tap into the ol' mental for reference if need be. Good luck, im kinda digging the side steps. After I saw a pic I went and looked some up lol here's what mine looks like. Congrats and enjoy your's.[IMG]https://uploads.tapatalk-cdn.com/20210226/b24d264ba66d9a091e84c6b9a2bd51f7.jpg

Sent from my SM-G970U using Tapatalk
You truck looks great! My front end has been blacked out which I actually don’t really like, especially the two bumper scoops. Oh well. So I took the running boards off my 03 and bolted them right up. I just like the way the look on the truck even though the consensus is to not put them on. I’ve always gone against the grain somewhat anyway. I feel like unless the truck is slammed, there is a lot of negative space inbetween the wheels. Oh well, what do I know lol. And I appreciate the help. I’m sure I wil have a lot of different issues going forward like this new one today...I’m getting a nice pulley squeal/grind at idle. Intermittent but it seems to be coming from either the ac/lower idler? Never knew these trucks had two belts until this morning lol.
 

·
Registered
TrailblazerSS
Joined
·
307 Posts
Thanks, not sure why it looks blurry when I posted that picture. Atleast on my phone I looks blurry lol. Anyhow no problem and yeah the ac has its own belt lol did you check the tensioner pulley? Take the tension off the belt and spin the pulley maybe the bearing in there is bad and the sound travels? Mine went bad and would squeal but I got to it before the grinding lol could be a different issue but one thing I have noticed is sound travels in these trucks lol one day I thought I was having transmission noise at idle but the honey comb in the converter broke apart in the exhaust and was rattling, even under the truck the sound seemed to becoming from the bell housing lol anyways I put long tube and catless y pipe and never heard that noise again

Sent from my SM-G970U using Tapatalk
 
1 - 13 of 13 Posts
Top