Chevy Trailblazer SS Forum banner

1 - 6 of 6 Posts

·
Registered
TrailblazerSS
Joined
·
176 Posts
Discussion Starter #1
I replaced my Bose Nav radio with a Clarion NX501 and I love the radio but my stock radio was louder than this one. The radio is routed to still use the Bose amp. I messed with all the EQ settings but nothing makes it go louder...its just more bass or treble. I see people have posted before that their aftermarket radio was louder than stock....I just don't see that with mine.

I was thinking of replacing the interior speakers with something better but I don't want to do that if it isn't going to help. I really don't want to install an amp but other than the blue-tooth function and USB, I feel like I downgraded everywhere else.
 

·
Jedi Knight
Saab 9-7x Aero
Joined
·
510 Posts
What connection from the radio is feeding the Bose amp? The RCA or speaker wires From amp?


Sent from my iPhone using Tapatalk
 

·
Registered
2008 Saab 9-7x Aero
Joined
·
236 Posts
check your radio harness. Some brands have an adjustment that you adjust with a screwdriver.
 

·
Registered
07 Black 2WD TBSS
Joined
·
193 Posts
I replaced my Bose Nav radio with a Clarion NX501 and I love the radio but my stock radio was louder than this one. The radio is routed to still use the Bose amp. I messed with all the EQ settings but nothing makes it go louder...its just more bass or treble. I see people have posted before that their aftermarket radio was louder than stock....I just don't see that with mine.

I was thinking of replacing the interior speakers with something better but I don't want to do that if it isn't going to help. I really don't want to install an amp but other than the blue-tooth function and USB, I feel like I downgraded everywhere else.
Your problem is in bold. I ran separate wires back to the bose amp location behind the rear seat, and picked up the speaker leads there (removing the factory POS amp from the system).
 

·
Registered
TrailblazerSS
Joined
·
176 Posts
Discussion Starter #5
Your problem is in bold. I ran separate wires back to the bose amp location behind the rear seat, and picked up the speaker leads there (removing the factory POS amp from the system).
I didn't do the install of the radio, I had an audio shop do the install. Can I just tell them this and they would know what it means?
 

·
Registered
TrailblazerSS
Joined
·
377 Posts
Something doesn't sound right then. I switched mine out with a Pioneer unit and there was a night and day difference. Even left the stock Bose amp and speakers. I would go back to the shop and voice your concerns.
 
1 - 6 of 6 Posts
Top