Chevy Trailblazer SS Forum banner

1 - 20 of 21 Posts

·
Registered
TrailblazerSS
Joined
·
148 Posts
Discussion Starter #1
I JUST GOT A TUNE FROM FASTMOTORSPORTS, E-FANS, JETTSTREAM 4INCH, HEATSOAKREDUCTION, SERVOS,CIRCLE D 3200, CATCH CAN, BATTERY & GROUND UPGRADE AND WENT TO THE TRACK AND OUT OF THREE RUNS MY BEST WAS A 14. WHATS GOING ON? IM SICK ON THE STOMACH!!! :wtf:
 

·
Premium Member
TrailblazerSS
Joined
·
2,590 Posts
my guess is it is going to be high DA...

if you dont know the DA, what was the temp..
 

·
Premium Member
Trailblazer SS
Joined
·
5,558 Posts
As Matt said what was the 60' time? How about the 1/8 mile time? What were the MPH at both the 1/8 mile and 1/4 mark? Just because it was 80 degrees doesnt mean anything, what was the actual DA? was the truck idling in the staging lanes?

If your down in the 2.1-2.2 60' time or your only at lets say 92-95mph then it sounds like a traction and heatsoak issue more than anything else.


We need alot more information to help you and just stating a time is not enough for anyone to help you. Do you have times from the truck before the mods with the supporting information as well?

Heck even on this board we have seen someone do plugs and wires and drop 3 tenths off their 1/8 mile time alone.

You have to take this subjectively and ask questions and analyze what is going on not just start ranting out and point fingers. Its not what you want to hear but remember most people only post their good times from the track, nobody likes to talk about their bad times at the track yet we all have had them
 

·
Registered
Trailblazer SS
Joined
·
905 Posts

·
Premium Member
06 TBSS
Joined
·
1,499 Posts
post your slip, track name, and date you went there. you will get your questions answered then.
 

·
Premium Member
TrailblazerSS
Joined
·
2,200 Posts
Temp has nothing to do

It was 80 degrees. What times should i run with these mods?
with DA. Post the date time and location of the runs as well as the slip and maybe we can figure it out.
 

·
Premium Member
'06 AWD
Joined
·
5,094 Posts
AWD...RWD....how did you leave/launch? Only reason I ask cuz I lost my mind and was leaving like a douche canoe and not taking advantage of my stall and 2400da doesn't help either.
 

·
MOST HATED
Trailblazer SS
Joined
·
3,915 Posts
Its the weather.
 

·
Registered
TrailblazerSS
Joined
·
148 Posts
Discussion Starter #18
yea im not blaming anyone, its just my feeling were so hurt after spending 2500 on parts and im running the same times my F250 was running. i talked with brandon today and he explained it to me that the temp plays a big part and i need to let him know the 60ft times , and 1/8, 1/4 and mph. so i will try it again this weekend. its just a big shock and there r no tuning shops down here that can check me out and make sure everything is right.. when i ran in mobile the 60ft was 1.9919 and the 330ft was 5.8296 and the 594ft was 7.8729 and the 1/8 was 8.4705 at 75.30mph.. lauching it from 13 or 1500 rpms on a faluken street tire full weight.
 

·
Registered
TrailblazerSS
Joined
·
148 Posts
Discussion Starter #19
brandon is a big help and so glad that i can call and ask ?s and get answers but im new at this and just wish i had someone at the track helping me out but i will get it sooner or later and big thanks to all of yall for replying and i will put my times on here and try n see how can i get the da or temp when im running.
 

·
Registered
TrailblazerSS
Joined
·
683 Posts
Hey man....get up with me. I can log your truck for you and see whats up. We could even log it at the track. Mobile 1/8 mile times will read about 3-4 tenths faster cause its only 600ft long. Post up your 1/4 mile times.

But I think its mainly the heat. My truck on motor is a full tenth slower 60ft, and 3 tenths slower through the 1/8th right now in this weather.
 
1 - 20 of 21 Posts
Top