Chevy Trailblazer SS Forum banner

1 - 5 of 5 Posts

·
Registered
TrailblazerSS
Joined
·
135 Posts
Discussion Starter · #1 ·
My 2007 3SS has 68215 miles on it. Upgraded engine parts to add around 100hp. Bought a Circle D 3200 converter. Circle D said the transmission won't hold up. Upgraded the transmission with Sonnax parts. Transmission has 2nd, 3rd, and rev only.
I was told I have an electrical issue and the trans is limp mode. Pulled the trans back out to check solenoids and other maybe issues. Solenoids work fine. Checked both fuse blocks, TCM fuses, OK. Checked wires and connections. Had no electrical going to TCM. In frustration, I changed the ignition switch. Turn switch to the ACC position the dash instrument lights come on. Run position same thing. Shut the key off and some dash lights stay on, radio lights still on. Mess with the key, some go off, radio still on. Turn key back to run and really turn key off hard. Everything but radio goes off. Wait about 20 seconds or so and some dash lights come back on by themselves.
ANY suggestions or help would be greatly appreciated. Thank you
 

·
Registered
Joined
·
460 Posts
Read the instructions that came with new switch or look it up. The switch has to be clocked properly to work right.

Sent from my SM-G965U using Tapatalk
 

·
Registered
2008 TBSS Red Jewel RWD
Joined
·
830 Posts
Correct ... If it's off my one tooth it will act weird. The other 08 that I had ate an ignition switch every 6 months like clockwork.

Sent from my moto z3 using Tapatalk
 
  • Like
Reactions: bowtie guy

·
Registered
TrailblazerSS
Joined
·
141 Posts
I replaced mine not to long ago. The new switch out of the box was way off in position from the old switch after taking it out and comparing the two. I had to move the gear on the new one to match the old one and everything went fine after that.
 

·
Registered
TrailblazerSS
Joined
·
245 Posts
My car is now experiencing EXACTLY the same as you describe. all lights come on (and stay on) but the car will not start. The lights and radio staying on perplexed me for awhile BUT is normal.
think about it. Under normal operating condition these things are programed to stay on UNTIL you open one of your doors to exit. Your accessories no nothing different. In any case, I've purchased a new starter to install next week. Still do not know if this is even the cause. I've lost 4th gear in the transmission too (likely unrelated but who knows, I rule out nothing at this point.)
 
1 - 5 of 5 Posts
Top