Chevy Trailblazer SS Forum banner

1 - 20 of 25 Posts

·
Registered
TrailblazerSS
Joined
·
164 Posts
Discussion Starter #1
Hey everyone,recently purchased a white v6 ls trailblazer around 6 months ago,finding myself bored with it very quick i found a black ss.
So i traded it in and got it,its the awd version,so it grips a little more than id like at times,but its a very nice truck.Ive had a couple lightnings in the past,and it makes me miss the rwd though.
I believe its got some kind of muffler delete,or something on it because its def not the stock exhaust.
Looking to do some LT's and mids,intake and a tune as my first mods.
Here it is:

:cheers1:
 

·
Premium Member
TrailblazerSS
Joined
·
1,381 Posts
Welcome !!!!
 

·
Registered
2007 tbss 2wd
Joined
·
270 Posts
welcome im in north wilmington
 

·
VetteWagon
07' summit white
Joined
·
486 Posts
welcome and congrats on the purchase. nice looking SS
 

·
Hooked on speed
06 Trailblazer SS
Joined
·
3,099 Posts
Welcome. Ya got the right color.
 

·
Registered
TrailblazerSS
Joined
·
164 Posts
Discussion Starter #9
I sent you an email from your site Fran! Im ready to go fast.
Youll remember me,i used to hang out at FSM back in the day.
 

·
Registered
TrailblazerSS
Joined
·
164 Posts
Discussion Starter #12
Hey thanks alot everyone,alot of good info on here been searching and reading for days.
One thing I noticed though,I drove my truck for the first time last night in a few days.
Drives fine,but on the highway when I do a WOT pull,the service stabilitrak light pops on and says it,then immediately goes off.I did it at least 4 times and it kept doing the same thing.
Is this a problem,or just some fluke?
 

·
Premium Member
TrailblazerSS
Joined
·
3,037 Posts
Welcome! Nice looking truck. What speed are you getting on it from when the stabilitrac light comes on? If you press down the traction control button on the side of the shifter it it will turn traction control off and hold it for 10 seconds and it will turn the stabilitrac off.
 

·
Premium Member
TrailblazerSS
Joined
·
3,037 Posts
Is is spinning from those speeds?
 

·
Registered
TrailblazerSS
Joined
·
164 Posts
Discussion Starter #17
I mean its awd so i dont think so lol,but its lost grip before and it didnt come on.
 

·
Premium Member
TrailblazerSS
Joined
·
3,037 Posts
I mean its awd so i dont think so lol,but its lost grip before and it didnt come on.
That's wierd. If the problem continues maybe you should have the dealer check it out. Good luck man
 

·
Registered
2008 AWD 3SS
Joined
·
947 Posts
Welcome!
 
1 - 20 of 25 Posts
Top