Chevy Trailblazer SS Forum banner
1 - 8 of 8 Posts

· Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hey guys im looking at getting back into a tbss. Found a 07 locally here in ne ohio thats pretty modified. Mods are lsa blower, lt headers, efans, tubular control arms and panhard bar along with a built trans and few other things im forgetting. My issue on potentially pulling the trigger on it is that after a about 15-20 min the warning lights all come on and engine rpm starts to stumble. Also when I went to shut it off the lock cylinder turned to the off position and I was able to take the key out but truck was still running and had full power still. I was thinking that the ignition switch was not installed correctly but also leaning toward a broken copper wire in the fuse block. Am I in the right direction of thinking or could this be something deeper? Don't wanna buy it and have it turn into a nightmare. Any help will be greatly appreciated and hoping you guys can get me in the right direction to hopefully have another ss again!
 

· Registered
'07 3SS 2WD
Joined
·
533 Posts
The typical fuse box issue will cause it to throw codes and die. Not stay running with the key out.
 

· Registered
Joined
·
629 Posts
I agree, fuse box issues will light up the dash.

not turning off, well that’s new, and could very well be an ignition switch.

both are inexpensive fixes. have the seller knock off a grand for the time and labor or find a different unit if you don’t want to deal with someone else’s project
 

· Registered
Joined
·
82 Posts
Could be ignition switch teeth are off. Could be something more nefarious. I'd see what all wiring they have done. They could have wired something wrong and is feeding power where it shouldn't be. But if they just replaced the ignition switch then probably didn't get it just right. See if they would take a grand off. Not unreasonable of an ask to fix their issue. Or, have them fix the issue first, then buy it.
 

· Registered
Joined
·
2 Posts
Discussion Starter · #8 ·
Just went and looked at the truck again today was gonna negotiate a price but had to leave early with a work emergency. I'm now leaning toward it being a wiring issue or tune issue. In the ten minutes I had it running no dash lights popped up aside from the check engine light. Kicking myself for not bringing my scanner with me to see what that was. I wouldn't be able to look at the tune in hp tuners until i bought it unfortunately. But truck sits and idles just fine like I said previously. Yet anytime you try and give it gas it stumbles and wants to die. You can slowly ease into it it tries to clear up but then begins to stumble again. Wondering if i should just walk away now or if you guys think it could still be possibly something simple. Just don't wanna get nickle and dimed to death if I purchase it and cant figure it out and have to take it to a shop. On the fence about the whole thing but would love to have the thing lol I miss my old ss dearly. Any more input would be greatly appreciated once again. Next time I do go over there to see it again I will have my damn scanner with me this time lol.
 
1 - 8 of 8 Posts
Top