Chevy Trailblazer SS Forum banner

1 - 18 of 18 Posts

·
Premium Member
06' TBSS 2WD
Joined
·
3,410 Posts
Discussion Starter #1
is a phawking slow pig. A consistently slow one at that. I only made 3 runs total last night, because all 3 were pretty much identical, within .01 of each other. I should have just entered the damn bracket shootout. lol

Anyways, here's the runs:

13.77 @101 w/2.126 60'
13.78 @101 w/2.150 60'
13.76 @101 w/2.145 60'

The DA was 1200' last night, so we had decent air. In much better air, back in early March, the best I ran was a 13.82 @99. So, in worse air, I only picked up .06, but picked up almost 2 mph. The only addition are the elec. fans. So, I guess the truck is obviously making more power, but it's just not showing in the ET. My 60's are horrible, and I def. think I'm doing something wrong, because it seems most everyone else with my mods are getting bottom 2.0's, and even high 1.9's. I'm not spinning at all, just bogging. I've heard it might be a TM thing pulling timing after doing a burnout, and the truck will launch soft due to the lack of timing. I bring the truck to about 1K rpm's, and flatfoot it on the 3rd yellow, launching in D. Who knows....I'm just looking for excuses now. :(

Anyways, here's a full list of mods:

CAI
de-screened MAF(tuned for BTW)
IEATSRT8 HSRK
IEATSRT8 heat shield
PCM4Less e-fan kit
PCM4Less tune
Cutout

I have the Yank SSTB3600 converter, PCM4Less tranny cooler kit, and servos ready to go in, so I guess I'll throw those in and run it in cooler weather and hope for the best. :)
 

·
Premium Member
2007 TBSS
Joined
·
4,834 Posts
Its probally just the weather.

I went out thursday night and I was off 3mph in the 1/8th. A vette I did was off 5mph with no changes to the car since winter and a couple of GTO's where off a couple tenths.

It wasn't hot at all just extremely muggy.
 

·
Premium Member
06' TBSS 2WD
Joined
·
3,410 Posts
Discussion Starter #3
See, that's just it, it wasn't muggy at all last night. Humidity was only 61%, DP was like 51°, and the pressure was 30.13, so the air was decent for the summer, but still, 1200' DA. Like I said though, before the e-fans and your tune Alvin, in much cooler weather, and better air in general, the truck was only able to pull 99 mph with the ADM tune, so the extra power I've noticed is def. there. :D
 

·
Registered
06 TBSS 2WD
Joined
·
570 Posts
Well, for 1200 DA it does seem slow, however, what is your raceweight? You 60's are killing your ET obvioulsly but I would think that your MPH would be higher for a 2WD in 1200 DA weather with those mods.

Leave the cutout capped next time as our stock exhaust systems aren't that bad.

I would think that you of at least gone 102-103mph but I don't know your raceweight, etc.. etc..
 

·
Premium Member
06' TBSS 2WD
Joined
·
3,410 Posts
Discussion Starter #7
My racewight is 4750, verified by scales at the track. Also, with my cutout closed, I lose over 1 mph.
 

·
Premium Member
2007 TBSS
Joined
·
4,834 Posts
What are the weather conditions? What is the actual altitude? you guys had to be higher than 1200. I was over 2000 just in charlotte the other day.

Also, how much gas?
 

·
Premium Member
06' TBSS 2WD
Joined
·
3,410 Posts
Discussion Starter #9
The altitude of the track is 480'. I went to weather underground and got all of the info at the time of my best run, and then went to my other site, entered it in, and it gave me the DA for that exact time. I had between an 1/8 and a 1/4 tank of gas at the time of the run.

At the time of my run, here are the weather conditions and DA:

Temp. - 68°
Dewpoint - 54°
Humidity - 61%
Baro. - 30.13

DA - 1123
 

·
Premium Member
06' TBSS 2WD
Joined
·
3,410 Posts
Discussion Starter #11
I guess I just got one of the slow ones! lol

Here's the kicker though, when I was in bone stock, and in about 0-100 DA air, the truck went 13.98 @99. So, with all the mods listed above, and only slightly worse in my opinion air, I only picked up 2 tenths and 2 mph. :(
 

·
Premium Member
2007 TBSS
Joined
·
4,834 Posts
I dont' think so.. Theres a big difference in 1000 ft of altitude. My truck took a big hit from the winter time.. I went froma 8.45 to a 8.75-8.8 when it got hot out again.
 

·
Premium Member
06' TBSS 2WD
Joined
·
3,410 Posts
Discussion Starter #13
Well, that's what I thought. But here's the kicker, in barely negative DA this past spring, with all the mods listed above, minus the fans, HSRK and shield, the truck ran an 8.81 in the 1/8, right at 82...like 81.9 mph. Yesterday, in the DA I ran in, my best 1/8 mi was 8.89 @81.46.
 

·
Premium Member
2007 TBSS
Joined
·
4,834 Posts
Sounds to me like the truck is going to pick up a solid couple tenths when the DA goes negative again.
 

·
Registered
06 TBSS 2WD
Joined
·
570 Posts
My racewight is 4750, verified by scales at the track. Also, with my cutout closed, I lose over 1 mph.
Hmm, that's about 200lbs more than mine but the MPH difference is 3-4mph and I don't use a cutout just a straight pipe in place of the factory muffler going to the stock rear resonator. I wouldn't think 200lbs would equal 3-4mph difference??? My 1/8th is also 83-84mph... hmm is the weight the ultimate killer on these things?
 

·
Registered
06 TBSS 2WD
Joined
·
570 Posts
Sounds to me like the truck is going to pick up a solid couple tenths when the DA goes negative again.
Obviously so will ever combustion engine on the planet Alvin. Is it possible that he had excessive KR. Did you log familyman?
 

·
Premium Member
06' TBSS 2WD
Joined
·
3,410 Posts
Discussion Starter #17
nope......nothing to log with. What would my truck have that cause any more KR than any other with similar mods? And don't say the cutout! lol
 
1 - 18 of 18 Posts
Top