Chevy Trailblazer SS Forum banner

1 - 17 of 17 Posts
L

·
Guest
Joined
·
0 Posts
Discussion Starter #1
right now i an running a set of ls1 fans and they work pretty well. i also have a set of 292's as well. the 292's pull 4600cfm's of air not really sure what the ls1 fans do nobody ever said. and with these hot temps around here will i benefit from putting in the other fans. i know the radiator is the main thing in cooling but by pulling more across it will cool better or should i just keep the fans i have in there. i know changing out the fans will require me to move the computers back a coupla of inches but they will fit. what do you guys think!!!
 

·
Premium Member
2007 TBSS
Joined
·
4,834 Posts
I've yet to hear someone complain about cooling problems with LS1 fans. Why go thru all the extra hassle?
 
L

·
Guest
Joined
·
0 Posts
Discussion Starter #4
what temps are you guys running in tx?? it has been 90-95 here with 75-80% humidity or xlose to that. i just have two fans and want to know which would be better. i love the heat its only here for a little while!!! i am not complaining about the ls1's at all they fit nice and look factory, 292's are a little cleaner looking tho!!! what are the coolant temps in you trucks with 160* t-stats mine got up to over 225 today!!!WTF thats a little too hot for me at least my tranny temps were at 185-195. i tried turning on the fans manually but that did not help tried turning the ac off for a few to see if anything would happen but it just dropped a bit
 

·
Founding Member!
2012 Ram 1500
Joined
·
5,053 Posts
We have those temps for about 7 months out of the year, you have them for 3. I do not have a 160 Tstat, so I cannot see that, but the temp gauge never goes over 210 on the dash
 

·
Premium Member
2007 TBSS
Joined
·
4,834 Posts
Something must be wrong. I sit at 190 at the hottest and its hot as crap here in muggy ass NC
 
L

·
Guest
Joined
·
0 Posts
Discussion Starter #7
do you think that i should go back to the stock tstat?? as the coolant does no spend enough time in the radiator to cool off???
 
L

·
Guest
Joined
·
0 Posts
Discussion Starter #8
ok same thing today 94* out i was going 35-45 on the highway with very little stopping and my engine temps got up to 223 and tranny got to 219 i did have the ac on! WTF is wrong with my truck
 
L

·
Guest
Joined
·
0 Posts
Discussion Starter #11
even if i turn them on by the DH it still wont cool off and i am not driving it hard either, i can see if i was out beating on it and the temps got up there but they still should not get that high!!!
 

·
Registered
06 TBSS 2WD
Joined
·
346 Posts
U need to check and make sure the fans are indeed coming on and that a relay isn't bad. You shouldn't see temps that high unless the settings are wrong in the tune.
 
L

·
Guest
Joined
·
0 Posts
Discussion Starter #13
yeah both of the fans are comming on.. its funny at 95* out it will run that hot with the ac but when the temps get to about 80-85 then i will see coolant temps around 195!!!
 
L

·
Guest
Joined
·
0 Posts
Discussion Starter #15
TTP's harness. could it be that my Tstat had failed and left open??? it is a SLP 160*
 

·
Registered
2006 TBSS
Joined
·
415 Posts
I have alvin's harness with ls1 fans on mine and I don't think I've seen it get over 200 yet and as alvin said it's hot as balls here lately. Have you checked to make sure your coolant isn't low? maybe you had a leak or something. Good luck figuring it out.
 
1 - 17 of 17 Posts
Top