Chevy Trailblazer SS Forum banner
1 - 9 of 9 Posts

·
Registered
TrailblazerSS
Joined
·
718 Posts
Discussion Starter · #1 · (Edited)
hey guys i took off out of my driveway normal and hit a small bump as i went from black top to pavement. right when i hit it it felt like the truck flew into nutral.

lost D and 3.

band? seal on acumulator ? piston?
or junk trans?

after reading in many places it seems as though it is the forward sprag assembly. has anybody a diagram or over replaced this before? PLEASE HELP....
 

·
Premium Member
Trailblazer SS
Joined
·
15,616 Posts
Ahh trans check! Not good
 

·
Registered
2006 TBSS
Joined
·
119 Posts
My transmission was slipping from 1 to 2 and 2 to 3, and I eventually lost 2nd gear altogether. GM tried to fix it and ended up replacing the entire transmission 3 days before the 5 yr 100k mile warranty was up.

Hope you are still under warranty, or, better yet--tear it apart and build a monster!!!
 

·
Registered
TrailblazerSS
Joined
·
718 Posts
Discussion Starter · #5 ·
mine has never slipped.. complete stock truck.. i change fluid at 30 and 60k same with transfer case. i dont beat it at all..

i hit a bump and BAM....felt like it was thrown into neutral.
 

·
Registered
TrailblazerSS
Joined
·
718 Posts
Discussion Starter · #6 ·
gear selector still goes through all the gears.

any GM techs that can help a suggestion?

i have a scanner and everything to check anything but im not good with transmissions..

i think im going to drop the pan and see what i can see... nothing seems to be worn as it never had a slip problem or any indication of getting worn. Some thing flat out just had to break, could be as simple as a seal. but I dont know
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top