Chevy Trailblazer SS Forum banner

1 - 20 of 23 Posts

·
Registered
2007 TBSS
Joined
·
32 Posts
Discussion Starter #1
I am looking to buy a JL Audio Stealthbox to get some bass in the tbss.

What color matches our interiors the best?

They have a SB-GM-TRLBLZR/10w3v3/DG - (Ebony)
and a SB-GM-TRLBLZR/10w3v3/TP - (Dark/Light Gray).


Looking for any owners who have one, and which one did you get?

Thanks,
Rick
 

·
Jedi Knight
Saab 9-7x Aero
Joined
·
510 Posts
I have a Saab 9-7x Aero and the color of mine matches great. It's kind of a light grey color. I could check the sub box to see if it says what color it might be.
 

·
Registered
2007 TBSS
Joined
·
32 Posts
Discussion Starter #3
Mav2u: were you able to get a color code?

Anyone else that has ordered a JL Audio Stealthbox, which one did you get: the ebony or the Dark/Light Gray one?

Thanks,
Rick
 

·
Jedi Knight
Saab 9-7x Aero
Joined
·
510 Posts
I'll try to remember to check for serial info on sub tomorrow.


Sent from my iPhone using Tapatalk
 

·
Registered
TrailblazerSS
Joined
·
95 Posts
if anybody need a toby box for any size of speaker let me know my buddy make them and believe me u don't need 2 subs with this kind of box clean deep bass
 

·
Jedi Knight
Saab 9-7x Aero
Joined
·
510 Posts
Sorry, looked on box but no info. Here is photo of it. Sounds badass in my truck an fits like a dream! 500 watts pushing it!!



Sent from my iPhone using Tapatalk
 

·
Premium Member
'08 Silver TBSS
Joined
·
4,535 Posts
Mine looks exactly as the photo above and I ordered Dark Gray/Ebony.
 

·
Registered
TrailblazerSS
Joined
·
76 Posts
I just recently ordered one from the JL Audio eBay page, and I checked the window sticker on my SS to verify the interior color as "Ebony", so that's what I went with. It hasn't arrived yet, but I'll let you know how that turns out and upload a pic...
 

·
Registered
2007 TBSS
Joined
·
32 Posts
Discussion Starter #10
Sounds good.....yeah my interior code says ebony also...pics would be greatly appreciated
 

·
Registered
TrailblazerSS
Joined
·
241 Posts
I have had one of these in my truck for years too. I push it with a JL amp that is suggested on their website.
 

·
Registered
2006 AWD
Joined
·
247 Posts
I'm running 2 12's now wishing I had more trunk space...but can't give up the BASS! lol
 

·
Registered
TrailblazerSS
Joined
·
76 Posts
Threw the box in back for a quick test-fit...I am pretty happy with the fitment, this is the first Stealthbox I've purchased (although I've wanted one for years with different vehicles I've owned). I do feel like the color of the carpet isn't as close of a match as I would have hoped for with a $700 product, but hopefully once I get everything installed I'll be so blown away by the sound that I won't care anymore. As mentioned above, I ordered the "Ebony" option from the JL Audio page on eBay.



 

·
Registered
TrailblazerSS
Joined
·
288 Posts
Keep us posted
 

·
Jedi Knight
Saab 9-7x Aero
Joined
·
510 Posts
Not sure if your carpet is lighter color or the box.
Either way, once covered and hooked to an amp you won't care anymore! Just sweet clean bass from the back is all you'll hear!
I assume yours is 2 ohm like mine? Just make sure you have a nice amp pushing 500 watts to make it move!
My Alpine mono amp rocks it nice!


Sent from my iPhone using Tapatalk
 

·
Registered
TrailblazerSS
Joined
·
76 Posts
yeah, I'm hoping to have the time to do the whole install this upcoming week, and I look forward to not caring about the subtle color difference soon enough!

It is 2 ohms, and the amp I bought is a Kenwood Excelon X500-1...hopefully that's sufficient.
 

·
Jedi Knight
Saab 9-7x Aero
Joined
·
510 Posts
That should work! Same as my Alpine amp. You should be rockin out soon!


Sent from my iPhone using Tapatalk
 

·
Registered
TrailblazerSS
Joined
·
76 Posts
System has been fully installed, and I am loving the Stealthbox. Curious if anyone else who has one bolted it down per JL's instructions or if you just slid it in place and whether or not there is really an advantage either way. I didn't want to relocate the air compressor switch/valve, and it seems to fit pretty snug without being bolted in place.

The only bummer is that now, and it may not even be related to this install (it could just have been shitty coincidental timing), I'm hearing an annoying ticking sound coming from under/behind my dash. :( I've poked around a bit and can't seem to pinpoint where the noise is coming from, and it's most noticeable at cold start and under acceleration (when I release the gas pedal it basically stops), but as I continue to drive it gradually quiets down over time to the point of being "barely there". Regardless, I don't want it there at all...if anyone has experienced a similar situation after a stereo install and found a solution or there's a known issue, please chime in!!!
 

·
Jedi Knight
Saab 9-7x Aero
Joined
·
510 Posts
I've left mine unbolted. It hasn't come out or moved yet. Comes out pretty easily if I need to get to the compressor stuff.

You put a new stereo in? Maybe you moved a wire or your new install has a wire or plug vibrating against something under the dash?
 
1 - 20 of 23 Posts
Top