Chevy Trailblazer SS Forum banner
1 - 5 of 5 Posts

·
Registered
TrailblazerSS
Joined
·
284 Posts
Discussion Starter · #1 ·
Ok, so I had made another thread where my truck has no oil pressure, no SES, no smoke.....Someone suggested an ignition switch problem. This got me thinking.....There have been a few times where I remove the key completely and the CHIME that starts with the key in the ignition stays on. :wtf: Battery seems to have gone bad also. Question is, could the ignition switch really have screwed up something mechanical like the oil pump? Maybe a short in the ignition caused the battery drainage? Truck is still at the dealer, as of 8AM this morning it still hasnt even been into service since there was a considerable amount of cars ahead of mine. I just doubt the dealership will be able to solve something like this.

Oh and I can't rag on them too much cuz truck has been tuned. Dont want to get on their bad side!
 

·
Registered
TrailblazerSS
Joined
·
284 Posts
Discussion Starter · #4 · (Edited)
let the dealer do their diagnostic work... they will fix it...

does the truck REALLY have no oil pressure... or is it just not reading on the gauge.
Thats the thing, didnt get to take a look myself. Heard a small tick probably meaning oil wasnt being picked up.....

Then fix it your fucking self!
Really wasnt expecting this^, If you just knew how incompetent and lazy the fuckers are around here, you'd say the same......:biteme: and GTFO of my thread!
 

·
Premium Member
07 TBSS 1SS AWD
Joined
·
17,281 Posts
i dont know what to tell you man...

if its the dealer you dont like... there are more out there... i dont know your situation.. but doubting the dealers service department yet taking the truck there anyways... your kind of stuck.

keep us posted... wish you were closer id tell you to bring it here... our techs actually do their job right...



 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top