Chevy Trailblazer SS Forum banner

81 - 93 of 93 Posts

·
Just a noob
TrailblazerSS
Joined
·
6,208 Posts
Don't mean to beat a dead horse, but I was just quoted $700 friggin dollars! I can't pay that. I won't pay it! Can anyone help please. When I turn on the air it comes out cold like it should on the drivers side upper vents, but heat comes out on the passenger side upper vents and I mean super hot! Someone please help
It's not hard to do. Just takes some time and simple tools. My thought is a few hours of my time is better than paying someone $700. Hell even if it was only $50 I'd still do it myself that way I know it was put back together correctly
 

·
Registered
TrailblazerSS
Joined
·
124 Posts
It's not hard to do. Just takes some time and simple tools. My thought is a few hours of my time is better than paying someone $700. Hell even if it was only $50 I'd still do it myself that way I know it was put back together correctly
I gave it a try, but I'm too large to fit under the dash. Need to hire a small person to help me. If you know of anyone send them my way please.
 

·
Registered
2008 AWD 3SS
Joined
·
947 Posts
I am going to try to do this on my truck soon. I didn't see where anyone ever posted the write up in the post. Any one have it that they can send it to me?

[email protected]
 

·
Registered
2007TrailblazerSS
Joined
·
137 Posts
if you pull the gas pedal out it frees up tons of room. whole fix took me 30 minutes
 

·
Registered
TrailblazerSS
Joined
·
22 Posts
I'm having this same issue i think. Clicking noise everytime I turn the truck on and the air is always coming out the dash vents and gets super hot.
 

·
Registered
9-7x Aero
Joined
·
291 Posts
When I change the mode from face to floor the air stops blowing on the face, but barely comes out of the floor vents. Just a tiny it of air. This wouldn’t be the mode actuator, would it?
Not sure if it’s relevant, but the rear floor vents blow at full force though.


Sent from my iPhone using Tapatalk
 

·
Premium Member
'08 Silver TBSS
Joined
·
4,499 Posts
The rear air has separate actuators independent to the front.
Sounds like your mode actuator is not switching fully to floor in the front.
 

·
Registered
06 TBSS
Joined
·
2 Posts
No control

I have the same problem, I heard there could be more than one actuator,
is that true? How do I know which one to replace?

Don't mean to beat a dead horse, but I was just quoted $700 friggin dollars! I can't pay that. I won't pay it! Can anyone help please. When I turn on the air it comes out cold like it should on the drivers side upper vents, but heat comes out on the passenger side upper vents and I mean super hot! Someone please help
 

·
Registered
Saab 9-7x Aero
Joined
·
6 Posts
I am having same issue after changing out my HVAC climate control for a less beat up looking one. I replaced old one and same issue persist. I hooked up Snap on scanner and i was getting a mode door code, so i replaced mode door actuator. Now i have no code but still no air coming from vents. I have tried calibrating it by either removing battery, removing hvac fuse b, or via scanner and still doesn't work. I do here all the actuators doing there self tests when i turn vehicle on but still know luck. Can someone please send me schematic, and calibration routine to [email protected].
 
81 - 93 of 93 Posts
Top