Chevy Trailblazer SS Forum banner
1 - 20 of 21 Posts

·
Premium Member
TrailblazerSS
Joined
·
2,787 Posts
Discussion Starter · #1 ·
Just plugged in a hid kit... Worked perfectly. Then turned the car off then back on heard a click and now no more hids.... No light ....nada. Help please
 

·
stupid white guy
TrailblazerSS
Joined
·
4,887 Posts
if you heard a pop, it could have been a fuse or relay or something. Check the obvious stuff first. Turn on lights and use test light to find out if you have power or not
 

·
Premium Member
TrailblazerSS
Joined
·
1,887 Posts
Mine was a fuse. Had to check every single damn one of them to find it too. :doh:
 

·
Registered
Joined
·
323 Posts
Did u find out what caused the fuse to pop?
 

·
Premium Member
TrailblazerSS
Joined
·
2,787 Posts
Discussion Starter · #5 ·
I actually tried a different buillb altogether non hid and it worked ... Could both hids have gone out
 

·
Mattmikemark
2006 Trailblazer SS
Joined
·
5,366 Posts
Sounds like a ballast problem... Where did you get your HID's?

I got mine from Jetttstream and after installation the low beams flickered BADLY. I sent him a video of it and he could tell right away that it was the bulb. Said it could only be a ballast if I had lost power completely (which sounds like your problem.)

Did you buy more than 1 kit? If so, replace the ballast with one from the fog light? :dunno:
 

·
Premium Member
TrailblazerSS
Joined
·
2,787 Posts
Discussion Starter · #7 ·
Fuses burnt a 15 and a 20 should I use a 30
 

·
Premium Member
TrailblazerSS
Joined
·
2,787 Posts
Discussion Starter · #9 ·
Just burnt 2 30 fuses
 

·
Premium Member
TrailblazerSS
Joined
·
2,787 Posts
Discussion Starter · #10 ·
Anyone
 

·
Premium Member
TrailblazerSS
Joined
·
2,787 Posts
Discussion Starter · #12 ·
Replaced the ballast and put a 30 fuse on it now to see
 

·
Registered
TrailblazerSS
Joined
·
6 Posts
you have a ballast problem. jetstreems hids are way over priced. go to ddm tuning u can get high's low's and fogs for about 100 bucks shipped to your door. within a week if they have in stock if not can be month or so.
 

·
Premium Member
Trailblazer SS
Joined
·
15,616 Posts
eBay baby!! And Luis. Your truck just hates you...
 

·
Registered
TrailblazerSS
Joined
·
6 Posts
correction u have a short if there blowing fuses 20 and 30 should not need more than 30 even 20... and the flickering is a power problem u need a wiring harness for the flickering problem the ballast is taking to much power to light the bulb corectly and the car is confused just need simple wire harness 15$ at ddm tuning..
 

·
Premium Member
TrailblazerSS
Joined
·
2,980 Posts
correction u have a short if there blowing fuses 20 and 30 should not need more than 30 even 20... and the flickering is a power problem u need a wiring harness for the flickering problem the ballast is taking to much power to light the bulb corectly and the car is confused just need simple wire harness 15$ at ddm tuning..
finally someone listens to me lol
 

·
Mattmikemark
2006 Trailblazer SS
Joined
·
5,366 Posts
correction u have a short if there blowing fuses 20 and 30 should not need more than 30 even 20... and the flickering is a power problem u need a wiring harness for the flickering problem the ballast is taking to much power to light the bulb corectly and the car is confused just need simple wire harness 15$ at ddm tuning..
I put in a new bulb and the flickering went away :dunno:
 

·
Premium Member
TrailblazerSS
Joined
·
2,787 Posts
Discussion Starter · #19 ·
I changed the ballast and get now flickering they are working great. Also unplugged and re-plugged everything... It's a beauty now


Sent from my iPhone using Taptalk
 

·
Premium Member
TrailblazerSS
Joined
·
2,787 Posts
Discussion Starter · #20 ·



Sent from my iPhone using Taptalk
 
1 - 20 of 21 Posts
Top