Chevy Trailblazer SS Forum banner
1 - 18 of 18 Posts

·
Registered
TrailblazerSS
Joined
·
321 Posts
Discussion Starter · #1 ·
I have a rattle that happens around 1500-1800 only when driving, can't hear it when it's parked. Sounds like a heatshield but I can't see anywhere it's rubbing, it's pretty loud. Only exhaust mod is a Res delete. Any suggestions?
 

·
Premium Member
Trailblazer SS
Joined
·
15,616 Posts
Maybe a weld was missed? My sounds like shit, since my cutout doesn't seal.. Now that is just obnoxious! I cant wait for my new exhaust
 

·
Registered
2008 Saab 97x Aero
Joined
·
906 Posts
Its probably just too close to something that at lower rougher idle it hits it... and I frkn hate cutouts my ecutout always leaked...i had five under warranty in a yr cause of it...
 

·
Registered
TrailblazerSS
Joined
·
284 Posts
Im having the same problem, but havent taken a look under the truck. Hope I can spot the problem quick cuz it is annoying as hell!
 

·
Premium Member
TrailblazerSS
Joined
·
2,655 Posts
Any hesitation? Could be cats breaking up. Also did you check all your rubber hangers? If one is wearing out the exhaust could move a little more.
 

·
Registered
TrailblazerSS
Joined
·
321 Posts
Discussion Starter · #12 ·
Ok, and lets say I accidentally beat the fuck out of them until they fell apart in my driveway, I *think* I could find an exhaust shop that would weld in pipe to replace them, of course only temporarily:bum:. Would I need a tune right away?
 

·
Premium Member
TrailblazerSS
Joined
·
2,655 Posts
You would just have codes for the rear O2s and maybe be a little lean so I'd avoid WOT.
 

·
Premium Member
TrailblazerSS
Joined
·
717 Posts
I got the same exact rattle. I had it up on my lift 3 days in a row. Sounds like its right under the drv side/middle of truck. Took the heat shield off that was right there..still there. Checked everything and couldnt find it. If i use a rubber mallet to the cat I can hear them rattling around a little bit. GM put cats on my truck 3k ago under warranty but since then I got a cutout/res delete...so bringing it back to them prob isnt gonna fly. Im thinking my cats are going again. Idk how it could possibly be...fuel trims are perfect +/- 5% and it runs great so I dont think im leaning them out.
 

·
Premium Member
TrailblazerSS
Joined
·
2,655 Posts
Ohok, I thought these trucks didn't have rear O2's.
Everything 96 and newer has a post cat O2 as part of the OBDII system. It doesn't affect performance just monitors if the cat is there.

Damn 2 sets of cats that quick? They have a longer warranty it should be covered. Or just gut 'em and trick the rear sensors.
 

·
Premium Member
TrailblazerSS
Joined
·
1,887 Posts
Sometimes resonators have this issue. They can be removed all together, or taken off and replaced, or taken off and repaired. Usually they are cut open and there is a flange inside that warps or the weld fails. Typically you will have to repack it with fiberglass or whatever it is in there. That may explain why you have it with no muffler. :cheers1:
 
1 - 18 of 18 Posts
Top