Chevy Trailblazer SS Forum banner

1 - 5 of 5 Posts

·
Registered
2007 Trailblazer SS
Joined
·
79 Posts
Discussion Starter #1
Replaced the alternator a few weeks ago, with a new battery didnt think anything of it! Randomly wouldn't start one night so i tried to jump it but was on the side of the road and couldn't get it started via jump so i had it towed under my insurance to my local repair shop. Said the new alternator is charging the battery too much, and causing issues. They proceeded to charge the battery back to "normal" and now it starts just fine. Got the alternator on rockauto so its under warranty, but thought i would post to see if anyone else had any other ideas beside just replacing the alternator under warranty . Should i try something else along with the alternator replacement?

Thanks again.
 

·
Registered
2008 TBSS Red Jewel RWD
Joined
·
812 Posts
Anything over 15 volts is to much. What was that alternator putting out?

Sent from my moto z3 using Tapatalk
 

·
Registered
2007 Trailblazer SS
Joined
·
79 Posts
Discussion Starter #4
Anything over 15 volts is to much. What was that alternator putting out?

Sent from my moto z3 using Tapatalk
Its putting out around 15.5 volts and its way too much! Turned the car off on the driveway, and it won't start now battery reads around 11.5v. I am going to order a replacement alternator under warranty from rockauto to start. please let me know if you have any other ideas
 

·
Registered
2007 Trailblazer SS
Joined
·
79 Posts
Discussion Starter #5
Its putting out around 15.5 volts and its way too much! Turned the car off on the driveway, and it won't start now battery reads around 11.5v. I am going to order a replacement alternator under warranty from rockauto to start. please let me know if you have any other ideas
UPDATE

New alternator installed and charging the battery around 14.7 to 15 V. After a drive and turning off the car the battery was 13.6 V and then it finally settled around 12.8 to 12.89 V about 15 minutes after I turned off the car.

Hopefully the problem is solved now
 
1 - 5 of 5 Posts
Top