Chevy Trailblazer SS Forum banner
1 - 20 of 23 Posts

·
Registered
TrailblazerSS
Joined
·
20 Posts
Discussion Starter · #1 ·
Well after giving the search button a good work out I figure its time to go ahead and post up. I am having a some crazy electrical issues with my 06 AWD TBSS. Whats going on is I'm riding down the road and the door locks will cycle and the the shift indicator goes form "drive" to "park" and back to "drive". It will do this several times on and average trip. I have been told it's putting the tranny into "limp mode" because the computer sees the truck is moving with the indicator in the park position. Anybody here seen this before? Any Ideas? Thanks in advance!
 

·
Registered
TrailblazerSS
Joined
·
20 Posts
Discussion Starter · #8 ·
I saw something similar to this but it was the tcm. Swapped it out and all was well.
Yessir I believe its already been changed. This truck has been molested in every possible way.

On a side note I just had the Battery load tested and one of my other suspicions was confirmed. Battery is shot. Money is tight this week so it's gonna have to wait till payday. It's not my daily driver so it will sit till then, no since chasing ground and other electrical issues till I know I have a good battery.
 

·
Old but not Dead Yet!
TrailblazerSS
Joined
·
9,572 Posts
Sounds like you are on the right track. But it might still be haunted!
 

·
Premium Member
07 2WD TrailblazerSS
Joined
·
10,061 Posts
Neutral safety switch is probably faulty, thats why the locks are acting up, because the switch keeps changing the signal inside without command.
Usually our trucks lock when we put them in drive and unlock when we put them in park!
 
1 - 20 of 23 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top