Chevy Trailblazer SS Forum banner

1 - 4 of 4 Posts

·
Registered
2007 RWD
Joined
·
21 Posts
Discussion Starter #1
Question for you guys, just got my cat back corsa touring installed along with my k&n. The cai was installed first and sure enough I got a engine on light. I removed the fuse # 29 for half an hour as some people suguested on another thread, and the light remained on. I finally disconnected the battery for 20 minutes and that cleared up the error code.
(By the way when the engine light was on, the transmission was shifting funny and chirping 2nd gear under normal driving conditions.) Next I installed the exhaust, which sounds awesome. My question is, do I need to do something to tell the computer in the car that there is less backpressure, or a new exhaust? Or will automatically adjust, un like the cai and the error code. Do I have to HAVE to reprogram the chip? I don’t want to void the warrenty. Can you program less aggressive tunes to play it safe?
Pleas help thanks george 2007 2wd
 

·
Registered
Joined
·
308 Posts
From what I understand, you have to tune for the CAI. Alvin can help you in that department. I believe he can "disguise" his tune from the dealer. But you need to contact him for the correct info on that. I would think that when you go to the dealer and they see the CAI and exhaust that would be more of a warranty issue than the computer that is reprogrammed but looks stock...I worry about warranty too but my worries fall more in the air conditioning/electrical department than motor...and my mods don't affect the air so screw it.
 

·
Registered
06 TBSS 2WD
Joined
·
346 Posts
That or you have some filter oil on your maf sensor making it read bad. Clean the maf also.
 
1 - 4 of 4 Posts
Top