Chevy Trailblazer SS Forum banner

1 - 14 of 14 Posts

·
Registered
TBSS AWD 3SS
Joined
·
266 Posts
Discussion Starter #1
Ok I have a 07 AWD with 57k on it and the last few weeks its been throwing a flashing SES P0300. I know the bank 1 one cats bad because for a year its been throwing a P0420. Whats weird is verified with a Dashhawk it seems to misfire like crazy on 3 always and ONLY under heavy load WOT. I thought this was because the bank one cat was clogged, but I notice on occasions cyl 8 was missing as the same time as 3. I have replaced plugs ngktr6 gapped at .35, factory wires, swapped injectors and coil packs, checked for vaccum leaks, pulled valve covers and no signs of broken springs. Fuel trims are fine on both banks, no oil or coolant loss, I am seing Knock(5 degrees atmost) and hearing clicking which sounds like a skipping bike chain only on heavy load starting around 4k rpms. The truck dosnt seem to be losing any power though, but im lost at this point.
 

·
Premium Member
06' AWD TBSS
Joined
·
1,364 Posts
The 5*of KR sounds like the cat being bad/clogged is causing the misfires. I had a problem with one of my cats being toasted, causing tons of misfires. Swapped the cat and no more misfires. Replace the cat and your problem should be solved...
 

·
Banned
Everything I work on
Joined
·
2,917 Posts
Ok I have a 07 AWD with 57k on it and the last few weeks its been throwing a flashing SES P0300. I know the bank 1 one cats bad because for a year its been throwing a P0420. Whats weird is verified with a Dashhawk it seems to misfire like crazy on 3 always and ONLY under heavy load WOT. I thought this was because the bank one cat was clogged, but I notice on occasions cyl 8 was missing as the same time as 3. I have replaced plugs ngktr6 gapped at .35, factory wires, swapped injectors and coil packs, checked for vaccum leaks, pulled valve covers and no signs of broken springs. Fuel trims are fine on both banks, no oil or coolant loss, I am seing Knock(5 degrees atmost) and hearing clicking which sounds like a skipping bike chain only on heavy load starting around 4k rpms. The truck dosnt seem to be losing any power though, but im lost at this point.
I'm going to be rudely blunt.

Instead of spending money on spark plugs, plug wires, injectors, coils, etc. Instead of going through all the BS of checking out every nook and cranny you have. Instead of chasing your tail:

Why not fix the fucking P0420 problem first?

Do you work in reverse at your job?
 

·
Resident NIP
06 SS Trailblazer
Joined
·
4,326 Posts
I'm going to be rudely blunt.

Instead of spending money on spark plugs, plug wires, injectors, coils, etc. Instead of going through all the BS of checking out every nook and cranny you have. Instead of chasing your tail:

Why not fix the fucking P0420 problem first?

Do you work in reverse at your job?
lol
 

·
High and Tight!!!
TrailblazerSS
Joined
·
2,959 Posts
Just do a cat delete...
 

·
=ЯΛWSSUM=
TrailblazerSS
Joined
·
1,137 Posts
do a temp. cat removal and check if that is the cure....
 

·
Premium Member
06' AWD TBSS
Joined
·
1,364 Posts
I'm sorry but I had to LOL at Billy's comment! My thoughts exactly, having issues for close to a year and not taking care fo the issue is just being careless and not taking care of your mode of transportation. It doesn't surprise me you are having other issues that are probably stemming from the faulty cat. Tossing money at it isn't going to solve the issue unless you figure out the root cause.
 

·
Registered
TBSS AWD 3SS
Joined
·
266 Posts
Discussion Starter #10
UPDATE Yes I'm a fool, I deleted the cats and no more misfires or Knock retard. Also trans shifts soo much smoother. Bank 1 cat was all jacked up causing a major restriction.
Its like a whole new truck.
 

·
Resident NIP
06 SS Trailblazer
Joined
·
4,326 Posts
UPDATE Yes I'm a fool, I deleted the cats and no more misfires or Knock retard. Also trans shifts soo much smoother. Bank 1 cat was all jacked up causing a major restriction.
Its like a whole new truck.
Good shit, how does it sound? Do you still have a stock muffler and stock resonator, if so I bet it sounds like shit. I have a cat delete with the smallest magnaflow they make and a res delete. Its fucking loud.
 

·
Registered
TBSS AWD 3SS
Joined
·
266 Posts
Discussion Starter #12
I have the same setup and its loud! I think throwing a 12" glasspack res on will cut it down some.
 

·
Banned
Everything I work on
Joined
·
2,917 Posts
UPDATE Yes I'm a fool, I deleted the cats and no more misfires or Knock retard. Also trans shifts soo much smoother. Bank 1 cat was all jacked up causing a major restriction.
Its like a whole new truck.
Nice!

Glad you got that shit handled. :coolthumb:
 

·
Resident NIP
06 SS Trailblazer
Joined
·
4,326 Posts
1 - 14 of 14 Posts
Top