Chevy Trailblazer SS Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
I just replaced sway links, tie rods, inner tie rods, upper and lower control arms, and upper and lower ball joints on both sides in the front of my 08 tbss this weekend. I got an alignment and 20 mins after driving I made a steady U-turn and then i heard and felt POP on my ftont right side. I tried driving forward but my front wheel locked up for a few seconds so the right tire was just squealing. I got out and looked and my right Wheel is inward while my left wheel and steering was straight. There is nothing broken that is visible from the outside. I got it towed home, got it in the air and tried wiggling both wheels but there is no play at all or in any of the parts. I tweaked with the tierods to get the wheels straight since I have to get another alignment anyway and I backed out of my garage and started turning and both wheels were cambered in at the top all sorts of different angles. Nothing looks or feels loose Does anyone know what could have caused this?. The steering wheel is straight in all the pics






Wheel Tire Land vehicle Car Vehicle
Cloud Sky Water Plant Road surface
Automotive parking light Land vehicle Car Vehicle Tire
Wheel Tire Vehicle Car Automotive tire

Tire Cloud Sky Car Wheel
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #6 ·
While factory spec is like 180ftlb it really likes around 220. Otherwise your alignment will slip like shown
I think you are right I my torque wrench only goes up to 150 and the blots were moving. Alignment shop didn't tighten them down enough I went down and tightened them all. I didn't really get to drive it around too much, only onto a trailer. Going to the shop tomorrow morning to talk with them so I'll find out then. Thank you for the ideas. Learned something new and helpful today👍
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #8 ·
I didnt know they were supposed to be torqued but im still learning everything because I don't trust shops for this reason exactly. I got two trusted shops but this place had a coupon for 25$ off so I went there but I learned that lesson to go to your trusted sources!
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #12 ·
Yes I replaced that, the alignment shop I took it too didn't torque down the bolts tight enough, but I think it something elese but i wont know till in the morning. I dropped it of at the shop that did it so they can fix it and im gonna watch them do it whether they like it or not
 
1 - 7 of 7 Posts
Top