Chevy Trailblazer SS Forum banner
1 - 20 of 63 Posts

·
Registered
TrailblazerSS
Joined
·
866 Posts
Discussion Starter · #1 ·
Ok I'll be installing a boost gauge later on this week, can anyone post some pics of where they connected it to a Magnacharger? Mine is a TVS1900. If you would rather send pics that would work also, PM me and I'll get you my # or email to [email protected]

Thanks guys, Bivins
 

·
Banned
Joined
·
18,856 Posts
Little Nipple, Back Passenger side of the blower....Thats the only spot in the whole system you can get a positive reading from. Its near the Intercooler water outlets.



 

·
Banned
Joined
·
18,856 Posts
On a TVS.....Before the Rotors?

Or Are you tapped somewhere else?
The only boost Reference I know of is on the rear of the blower.
Got any pictures?
I surely hope you dont have a Boost Referenced pump activation hooked to a Vacuum only reference point, that would mean it never activates.



 

·
Banned
Joined
·
18,856 Posts
The only think I know of on the front is the Vacuum Ports on the front Drivers sides right behind the alternator.....Other than that the only port I have ever seen on EITHER of my TVS Blowers was at the rear.



 

·
Banned
Joined
·
18,856 Posts
These Ports are not Boost reference.



The Port you see on the Rear Left with a Black Cap on it is the only boost reference I know of on these blowers unless there is multiple different blower castings out there.





 

·
Banned
Joined
·
18,856 Posts
i dont have anything on the back of mine. this is the drivers side
YOu are correct, if that goes into the Lower portion of the intake, thats a boost reference. But Ive had a 1900 and now the 2300, both have had ports at the rear left side As I just pictured, How old is your 1900? I bet its an Early model or someonee added that.



 

·
Banned
Joined
·
18,856 Posts
Weird...My 1900 is from two years ago, and the 2300 is mere months from production and mine are on the rear. Ill have to look and see if I have a second one on the drivers side, but I would have surely noticed something like that because thats right near where the MAP sensor goes.



 

·
Premium Member
TrailblazerSS
Joined
·
1,910 Posts
mines from last aug. and i just double checked mine now and the only thing on the back of mine are the coolant hoses. idk. im just special i guess :dunno:
 

·
Premium Member
TrailblazerSS
Joined
·
1,910 Posts
1900 on the left? 2300 on the right? mine looks like the one on the left but its got a 5 volt plug thing instead of that black plugged thing
 

·
Premium Member
2wd Turbo
Joined
·
11,126 Posts
Here is a rear shot of my old front drive 2300!

Yous is in a different place then both of my 2300!:2cents: WERD!\

rear shot! The red arrow is the port. They come with a rubber cap...



One more side view.. you can see it here too!

 
1 - 20 of 63 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top