Chevy Trailblazer SS Forum banner
1 - 15 of 15 Posts

·
Premium Member
2006 TBSS (LT Based)
Joined
·
5,978 Posts
Discussion Starter · #1 ·
Mine started running really strange today, the check engine light came on and the guy at Autozone said it read as cylinder #4 misfire. So it could be the plug, the wire or the coil pack.

The plug and wire is easy, but Autozone wants $120.00 for the coil pack. Any advice?
 

·
Premium Member
2006 TBSS (LT Based)
Joined
·
5,978 Posts
Discussion Starter · #3 ·
Junk yard?
Thanks, but the chances of me finding a TBSS in a junkyard around here is pretty slim...but I will call a few of them.

Are the 06 coil packs the same as the 07-09?
 

·
Premium Member
2006 TBSS (LT Based)
Joined
·
5,978 Posts
Discussion Starter · #7 ·
I have extra coil packs in my stock FS thread.
I PM'd you to ask about them but you didn't reply, that's why I posted this thread. How much for two shipped to 23663?
 

·
moar cowbell
Trailblazer
Joined
·
6,426 Posts
Thanks, but the chances of me finding a TBSS in a junkyard around here is pretty slim...but I will call a few of them.

Are the 06 coil packs the same as the 07-09?
they should all be the same. I have a '06 w/ the 5.3 and I have the same coil packs as well... you're not limited to just the ss model.
 

·
Premium Member
2006 TBSS (LT Based)
Joined
·
5,978 Posts
Discussion Starter · #12 ·
As it turns out, my problem isn't the coil. Swapped #4 with #1 and the problem didn't move with it. My next step is to change the plug and wire, after this fuel injection cleaner has run out through this tank of gas. I really hope it's not a bad/burnt valve, but I'll eliminate everything else first.

Any other suggestions?
 

·
stupid white guy
TrailblazerSS
Joined
·
4,887 Posts
Having trouble with my #8 too. Reads 100+ misfires on WOT heavy load runs. Moved wire....didn't move trouble. Going to swap coils when I get home and see if it moves.

Keep us updated.
 

·
Premium Member
2006 TBSS (LT Based)
Joined
·
5,978 Posts
Discussion Starter · #15 ·
Having trouble with my #8 too. Reads 100+ misfires on WOT heavy load runs. Moved wire....didn't move trouble. Going to swap coils when I get home and see if it moves.

Keep us updated.
I added a large bottle of Lucas Fuel Injector Cleaner yesterday, and the wife said it didn't hesitate once today. I'll see how it does over the next few days.
 
1 - 15 of 15 Posts
Top