Chevy Trailblazer SS Forum banner

1 - 4 of 4 Posts

·
Registered
TrailblazerSS
Joined
·
12 Posts
Discussion Starter #1
I've read alot on this but couldnt get any definitive answer on resolution or cause.. I was driving and had the a/c on working great when all of a sudden it cuts out starts blowing warm air and noticed my temp gauge went to 0 truck was running fine other wise no loss of power and definately no signs of overheating.. Truck is basically bone stock.. About 87k on engine..

I dont want go to dealer not knowing exactly what is wrong... Not for the money but i just dont want them pulling apart the motor chasing their tails..

My questions.. Whats the "link" between the a/c compressor temp gauge and fAns? Is it a fuse i can check? Should i bother going this route?

Also noticed some weird dash light that appears to be "cruise control" indicator has come on but i cant shut that off...

Any help is much appreciated!!
 

·
Registered
TrailblazerSS
Joined
·
12 Posts
Discussion Starter #2
Disconnected the battery everything went back to normal.. Hasnt flinched yet..
 

·
Registered
TrailblazerSS
Joined
·
12 Posts
Discussion Starter #3
From the day i first posted to today.. Issue has not come back... Unbelievable that any dealer could have replaced a number of things costing thousands...
 

·
Registered
TrailblazerSS
Joined
·
144 Posts
I've heard the ambient temp gauge is tied into all kinds of things, and can cause your ac to stop blowing cold, but haven't heard of it turning fans off. Pic of "cruise" light? Have you tried turning cruise on and off?
 
1 - 4 of 4 Posts
Top