Key is stuck in ignition - Chevy Trailblazer SS Forum
 

Go Back   Chevy Trailblazer SS Forum > TBSS Modifications > TBSS How To Section

TBSS How To Section Helping everyone out.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old May-04-11, 09:05 AM   #1
 
41510SS's Avatar

Real Name: N/A
Member # 9212
Join Date: Aug 2010
Status: Offline
Location: BAY AREA
Posts: 23
iTrader: (0)
Casino cash: $58199
Like: 0
Liked 0 Times in 0 Posts
Rep Power: 41510SS is an unknown quantity at this point
Default Key is stuck in ignition

Just like the title says, went to turn on the truck and it acted as if it wanted to keep on starting, so after hearing a grinding sound coming from the engine bay, I tried turning the key to off now the keys are stuck to the ignition. The starter was replaced in September, 2010 as well as ignition switch both were done at the same time. What gives? cannot take keys out from the ignition. Any ideas or help would be appreciated.
  Reply With Quote
Sponsored Links
Advertisement
 
Old May-04-11, 09:06 AM   #2
The one and only JJ
 
M T pockets's Avatar

Real Name: JJ
Member # 5
Join Date: Jun 2007
Status: Offline
Location: C A L I F
Posts: 14,071
iTrader: (2)
Casino cash: $660400
Like: 0
Liked 17 Times in 13 Posts
Rep Power: M T pockets has a spectacular aura aboutM T pockets has a spectacular aura aboutM T pockets has a spectacular aura about
Default

take battery out and take key out.
__________________
When U grow-up u can only dream that U had my life! lol.
  Reply With Quote
Old May-04-11, 10:29 AM   #3
 
41510SS's Avatar

Real Name: N/A
Member # 9212
Join Date: Aug 2010
Status: Offline
Location: BAY AREA
Posts: 23
iTrader: (0)
Casino cash: $58199
Like: 0
Liked 0 Times in 0 Posts
Rep Power: 41510SS is an unknown quantity at this point
Default

Update, I was able to remove the key by removing the steering column trim cover. I pushed in a small electric cyclinder that is located next to were you would remove the ignition switch. I even removed the ignition switch and tried swapping it with another one that I had. Still nothing, the key still gets stuck onto the ignition the truck will not start and I still have to push in the cyclinder to release my key. Has this happened to any of you?
  Reply With Quote
 
Old May-04-11, 01:21 PM   #4
aka RADIO SHACK
 
rrmccabe's Avatar

Real Name: Rich
Member # 243
Join Date: Jun 2007
Status: Offline
Location: Ankeny IA
Posts: 17,584
iTrader: (2)
Casino cash: $977490
Like: 155
Liked 1,045 Times in 650 Posts
Rep Power: rrmccabe is a splendid one to beholdrrmccabe is a splendid one to beholdrrmccabe is a splendid one to beholdrrmccabe is a splendid one to beholdrrmccabe is a splendid one to beholdrrmccabe is a splendid one to beholdrrmccabe is a splendid one to beholdrrmccabe is a splendid one to behold
Default

There is some type of theft deterant on the truck. I know if you run battery down with key on it will stick in. Its dumber than crap if you ask me.

I have had to put cables on truck when I was working on it to get the key out.
__________________
  Reply With Quote
Old May-04-11, 01:31 PM   #5

 
TWO-TONS-OF-FUN's Avatar

Real Name: Greg
Member # 1248
Join Date: Nov 2007
Status: Offline
Location: Gurnee, IL
Posts: 17,281
iTrader: (27)
Casino cash: $1997762
Like: 18
Liked 170 Times in 55 Posts
Rep Power: TWO-TONS-OF-FUN Gives oral for rep pointsTWO-TONS-OF-FUN Gives oral for rep pointsTWO-TONS-OF-FUN Gives oral for rep pointsTWO-TONS-OF-FUN Gives oral for rep pointsTWO-TONS-OF-FUN Gives oral for rep pointsTWO-TONS-OF-FUN Gives oral for rep pointsTWO-TONS-OF-FUN Gives oral for rep pointsTWO-TONS-OF-FUN Gives oral for rep pointsTWO-TONS-OF-FUN Gives oral for rep pointsTWO-TONS-OF-FUN Gives oral for rep pointsTWO-TONS-OF-FUN Gives oral for rep points
Default

did you get the reply to the pm i sent you?

check to make sure the BSIS solenoid is working properly...

brake shift interlock solenoid. is located on the shifter assembly under the center console.

also make sure the ignition switch is timed(installed properly)correctly on the gear when installed.
  Reply With Quote
Old May-20-11, 04:45 PM   #6
TT AWD SS Pwrd Camry
 
gn2beatu's Avatar

Real Name: Walter
Member # 12143
Join Date: May 2011
Status: Offline
Location: West Bend WI
Posts: 5,805
iTrader: (8)
Casino cash: $727000
Like: 71
Liked 310 Times in 214 Posts
Rep Power: gn2beatu Gives oral for rep pointsgn2beatu Gives oral for rep pointsgn2beatu Gives oral for rep pointsgn2beatu Gives oral for rep pointsgn2beatu Gives oral for rep pointsgn2beatu Gives oral for rep pointsgn2beatu Gives oral for rep pointsgn2beatu Gives oral for rep pointsgn2beatu Gives oral for rep pointsgn2beatu Gives oral for rep pointsgn2beatu Gives oral for rep points
Default

Two things can happen here.

1. The solenoid is bad....not as likely as 2
2. There is a wire on bottom side of column....white I think, It rubs through right on a bracket or clip. Look for this. Odds are if that wire rubbed through it also blew a fuse. I had to fix this on a customers truck once. I guess its kinda common. Just put tape around the wire, and cut a piece of vacuum hose to wrap around brackets edge.

Good luck.
  Reply With Quote
Old May-20-11, 07:49 PM   #7
alienSS
 
2NREATR's Avatar

Real Name: Everett
Member # 3870
Join Date: Oct 2008
Status: Offline
Location: Silverdale, WA
Posts: 3
iTrader: (0)
Casino cash: $52000
Like: 0
Liked 2 Times in 1 Post
Rep Power: 2NREATR has a spectacular aura about2NREATR has a spectacular aura about
Default

Mine did the same thing, turned out to be a dead battery from an FM modulator I installed & left turned on for a long time when parked (like 2 months -duh!) charged the battery & it's all good!
  Reply With Quote
Old May-18-12, 11:52 AM   #8

Real Name: mark
Member # 16686
Join Date: May 2012
Status: Offline
Location: warren mi
Posts: 8
iTrader: (0)
Casino cash: $54385
Like: 0
Liked 0 Times in 0 Posts
Rep Power: eastside ss ls2 is an unknown quantity at this point
Default hey

Im haveing the same problem how did u fix it
  Reply With Quote
Old May-18-12, 05:09 PM   #9

Real Name: jose
Member # 11499
Join Date: Feb 2011
Status: Offline
Location: texas
Posts: 567
iTrader: (4)
Casino cash: $168700
Like: 0
Liked 2 Times in 2 Posts
Rep Power: LaBrick2006 has a spectacular aura aboutLaBrick2006 has a spectacular aura about
Default

I don't know how to fix this but welcome to the forum as this is your first post
  Reply With Quote
Old Jan-05-17, 04:35 PM   #10
 
MOOVS's Avatar

Real Name: Maury
Member # 47065
Join Date: Feb 2016
Status: Offline
Location: Canada
Posts: 57
iTrader: (0)
Casino cash: $65000
Like: 1
Liked 2 Times in 2 Posts
Rep Power: MOOVS is an unknown quantity at this point
Default

Same thing just happened to me... did anyone have a fix ? where is this FM Modulator thing?
New starter and ignition switch 1 month ago... truck will not engage the starter and key will not come out of the ignition.....?
Problem just came out of the blue battery seems to have all kinds of juice
__________________
Awd 07 3SS...my daily....bolt ons..polished rims..hptune.
A work in progess
  Reply With Quote
Old Jan-05-17, 07:29 PM   #11

Real Name: Steve
Member # 1658
Join Date: Jan 2008
Status: Offline
Location: land of the prius
Posts: 630
iTrader: (5)
Casino cash: $145300
Like: 0
Liked 2 Times in 2 Posts
Rep Power: The Anti-prius is on a distinguished road
Default

Had this happen to the family tb ext. It was the ignition switch. Did three switches in that truck before we got one that lasted.
__________________
Wrecking the planet singlehandedly
  Reply With Quote
Old Jan-05-17, 09:28 PM   #12
 
MOOVS's Avatar

Real Name: Maury
Member # 47065
Join Date: Feb 2016
Status: Offline
Location: Canada
Posts: 57
iTrader: (0)
Casino cash: $65000
Like: 1
Liked 2 Times in 2 Posts
Rep Power: MOOVS is an unknown quantity at this point
Default

Thx...gunna put my stock one back in...changed it when i was havin a starter issue. .new one was Delco to
__________________
Awd 07 3SS...my daily....bolt ons..polished rims..hptune.
A work in progess
  Reply With Quote
Old Jan-07-17, 08:35 AM   #13
 
MOOVS's Avatar

Real Name: Maury
Member # 47065
Join Date: Feb 2016
Status: Offline
Location: Canada
Posts: 57
iTrader: (0)
Casino cash: $65000
Like: 1
Liked 2 Times in 2 Posts
Rep Power: MOOVS is an unknown quantity at this point
Default

Well no go with ignition switch... Same problem... now I can get the key out as I have access to the solenoid button.... just noticed ignition A fuse in fuse box under hood number 34 was blown... swapped it with number 35 for a quick fix and on first try to start it blew it again instantly....Grrrrrr
Anybody been down this road???
__________________
Awd 07 3SS...my daily....bolt ons..polished rims..hptune.
A work in progess
  Reply With Quote
Old Jan-10-17, 09:18 AM   #14
 
MOOVS's Avatar

Real Name: Maury
Member # 47065
Join Date: Feb 2016
Status: Offline
Location: Canada
Posts: 57
iTrader: (0)
Casino cash: $65000
Like: 1
Liked 2 Times in 2 Posts
Rep Power: MOOVS is an unknown quantity at this point
Default

Its fixed!
Bad starter soleniod on 3 week old starter...causing fuse 34 (ignition A) to blow not allowing key to turn back.
__________________
Awd 07 3SS...my daily....bolt ons..polished rims..hptune.
A work in progess
  Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.1.0

All times are GMT -7. The time now is 04:41 AM.

 
Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Content Relevant URLs by vBSEO 3.6.1
vB.Sponsors
Copyright 2007-2015 Tony Lukezic